summary refs log tree commit diff
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2021-09-26 06:10:49 +0000
committerMathieu Othacehe <othacehe@gnu.org>2021-10-02 10:54:36 +0000
commit087e3cbddea9c50b21e7846138e1199aea30bb0d (patch)
tree90733ba7a1aaf3107e918dedcfa42be9bbffd20c
parent09b72091d0d8320a764c7889376c4d273261f54c (diff)
downloadguix-087e3cbddea9c50b21e7846138e1199aea30bb0d.tar.gz
gnu: gsettings-desktop-schemas: Update to 40.0.
* gnu/packages/gnome.scm (gsettings-desktop-schemas): Update to 40.0.
[source]: Fix the URI.
[arguments]: Remove trailing #t.
-rw-r--r--gnu/packages/gnome.scm13
1 files changed, 6 insertions, 7 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 6afd815450..b658467928 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -2689,16 +2689,16 @@ on the GNOME Desktop with a single simple application.")
 (define-public gsettings-desktop-schemas
   (package
     (name "gsettings-desktop-schemas")
-    (version "3.34.0")
+    (version "40.0")
     (source
      (origin
       (method url-fetch)
       (uri (string-append "mirror://gnome/sources/" name "/"
-                          (version-major+minor version)  "/"
+                          (version-major version)  "/"
                           name "-" version ".tar.xz"))
       (sha256
        (base32
-        "1bayr76aylawf2fhyjhv9zgk4kpv7ivrrmd80khb0h3h1wk092r8"))))
+        "11an29br55dp0b26kfqlrfxj19glfrmhcdpds2n1w9n04gq3pf7i"))))
     (build-system meson-build-system)
     (arguments
      '(#:phases (modify-phases %standard-phases
@@ -2707,13 +2707,12 @@ on the GNOME Desktop with a single simple application.")
                       (let ((theme (assoc-ref inputs "gnome-backgrounds")))
                         (substitute* (find-files "schemas"
                                                  "\\.gschema\\.xml\\.in$")
-                          ;; Provide the correct file name of the default GNOME
-                          ;; background, 'adwaita-timed.xml'.
+                          ;; Provide the correct file name of the default
+                          ;; GNOME background, 'adwaita-timed.xml'.
                           (("@datadir@/backgrounds/gnome")
                            (string-append theme "/share/backgrounds/gnome"))
                           ;; Do not reference fonts, that may not exist.
-                          (("'Source Code Pro 10'") "'Monospace 11'"))
-                        #t))))))
+                          (("'Source Code Pro 10'") "'Monospace 11'"))))))))
     (inputs
      `(("glib" ,glib)
        ("gnome-backgrounds" ,gnome-backgrounds)))