summary refs log tree commit diff
diff options
context:
space:
mode:
authorTimotej Lazar <timotej.lazar@araneo.si>2023-06-24 21:27:32 +0200
committerLudovic Courtès <ludo@gnu.org>2023-07-11 16:05:50 +0200
commit09d1e04230fd96556e9d721e3dfb21cb2e465654 (patch)
tree10c7a6ee9e47726cd4430c4bfeef72aa331ceb9f
parentf561e8a0eddc818eb2cb1a5b0bddcb90436da97b (diff)
downloadguix-09d1e04230fd96556e9d721e3dfb21cb2e465654.tar.gz
gnu: qbittorrent{,-nox}: Use qt-build-system.
CMake is now upstream’s preferred build system.

* gnu/packages/bittorrent.scm (qbittorrent)[build-system]: Use qt-build-system.
[arguments]: Drop custom wrap phase. (Re-)enable tests.
[inputs]: Remove input labels. Drop qtbase-5.
[native-inputs]: Drop pkg-config.
(qbittorrent-nox)[arguments]: Adjust configure-flags. Keep the wrap-qt phase
since the non-GUI version is also a QT program.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/bittorrent.scm44
1 files changed, 12 insertions, 32 deletions
diff --git a/gnu/packages/bittorrent.scm b/gnu/packages/bittorrent.scm
index ce5e7ca3d7..4266e7af1f 100644
--- a/gnu/packages/bittorrent.scm
+++ b/gnu/packages/bittorrent.scm
@@ -40,6 +40,7 @@
   #:use-module (guix build-system cmake)
   #:use-module (guix build-system gnu)
   #:use-module (guix build-system python)
+  #:use-module (guix build-system qt)
   #:use-module (guix build-system glib-or-gtk)
   #:use-module ((guix licenses) #:prefix l:)
   #:use-module (guix gexp)
@@ -461,36 +462,19 @@ desktops.")
        (file-name (git-file-name name version))
        (sha256
         (base32 "1r4vqlwmvg7b0ibq53m7ascyykv3v66qxlwfi0zmmi1ig7rlkxkk"))))
-    (build-system gnu-build-system)
+    (build-system qt-build-system)
     (arguments
-     `(#:configure-flags
-       (list (string-append "--with-boost-libdir="
-                            (assoc-ref %build-inputs "boost")
-                            "/lib")
-             "--enable-debug"
-             "QMAKE_LRELEASE=lrelease")
-       #:modules ((guix build gnu-build-system)
-                  (guix build qt-utils)
-                  (guix build utils))
-       #:imported-modules (,@%gnu-build-system-modules
-                           (guix build qt-utils))
-       #:phases
-       (modify-phases %standard-phases
-         (add-after 'install 'wrap-qt
-           (lambda* (#:key outputs inputs #:allow-other-keys)
-             (let ((out (assoc-ref outputs "out")))
-               (wrap-qt-program "qbittorrent" #:output out #:inputs inputs))
-             #t)))))
+     (list #:configure-flags #~(list "-DTESTING=ON")
+           #:test-target "check"))
     (native-inputs
-     (list pkg-config qttools-5))
+     (list qttools-5))
     (inputs
-     `(("boost" ,boost)
-       ("libtorrent-rasterbar" ,libtorrent-rasterbar)
-       ("openssl" ,openssl)
-       ("python" ,python-wrapper)
-       ("qtbase" ,qtbase-5)
-       ("qtsvg-5" ,qtsvg-5)
-       ("zlib" ,zlib)))
+     (list boost
+           libtorrent-rasterbar
+           openssl
+           python-wrapper
+           qtsvg-5
+           zlib))
     (home-page "https://www.qbittorrent.org/")
     (synopsis "Graphical BitTorrent client")
     (description
@@ -510,11 +494,7 @@ features.")
       (arguments
        (substitute-keyword-arguments (package-arguments base)
          ((#:configure-flags configure-flags)
-          #~(append #$configure-flags
-                    (list "--disable-gui")))
-         ((#:phases phases)
-          #~(modify-phases #$phases
-              (delete 'wrap-qt)))))
+          #~(cons "-DGUI=OFF" #$configure-flags))))
       (inputs
        (modify-inputs (package-inputs base)
          (delete "qtsvg-5"))))))