summary refs log tree commit diff
diff options
context:
space:
mode:
authorAndrew Tropin <andrew@trop.in>2022-05-07 14:35:51 +0300
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-06-22 08:20:27 +0200
commit0e380c339b43ba38700e31c4a483e4dfc535d104 (patch)
treebde878eea450fa8dd8f137f2800f1a2d139dfce2
parent1147e0bee372e509873ce0b06d1863770c0951cb (diff)
downloadguix-0e380c339b43ba38700e31c4a483e4dfc535d104.tar.gz
gnu: Add emacs-consult-eglot.
* gnu/packages/emacs-xyz.scm (emacs-consult-eglot): New variable.

Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/emacs-xyz.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index dc59e828b7..9eb8b2182d 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -9055,6 +9055,27 @@ replaced with the directory you choose.")
 and present results either as single emails or full trees.")
     (license license:gpl3+)))
 
+(define-public emacs-consult-eglot
+  (package
+   (name "emacs-consult-eglot")
+   (version "0.2.0")
+   (source (origin
+            (method git-fetch)
+            (uri (git-reference
+                  (url "https://github.com/mohkale/consult-eglot")
+                  (commit (string-append "v" version))))
+            (sha256
+             (base32 "1qxk1npxbf8m3g9spikgdxcf6mzjx6cwy3f5vn6zz5ksh14xw3sd"))
+            (file-name (git-file-name name version))))
+   (build-system emacs-build-system)
+   (propagated-inputs (list emacs-consult emacs-eglot))
+   (home-page "https://github.com/mohkale/consult-eglot")
+   (synopsis "Consulting-read interface for eglot")
+   (description "This package acts as a parallel of consult-lsp for eglot and
+provides a front-end interface for the workspace/symbols LSP procedure
+call.")
+   (license license:gpl3+)))
+
 (define-public emacs-marginalia
   (package
     (name "emacs-marginalia")