summary refs log tree commit diff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-07-12 11:52:58 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-07-12 23:23:24 -0400
commit0fc3d5a6d45b9ea6747d7d1d200f92dd4a5dee4c (patch)
tree33b9559406baabdf1500f7f15030adfca6ffa696
parentef82f344824f63d7b1fe00062b23c21297182e98 (diff)
downloadguix-0fc3d5a6d45b9ea6747d7d1d200f92dd4a5dee4c.tar.gz
gnu: sushi: Use new style inputs.
* gnu/packages/gnome.scm (sushi)[native-inputs, inputs]: Use new style.
-rw-r--r--gnu/packages/gnome.scm40
1 files changed, 20 insertions, 20 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 880ff1f0bc..9a05e844b0 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -1608,27 +1608,27 @@ sharing to the masses.")
                  `("GI_TYPELIB_PATH" suffix
                    (,(getenv "GI_TYPELIB_PATH"))))))))))
     (native-inputs
-     `(("glib:bin" ,glib "bin")
-       ("gettext" ,gettext-minimal)
-       ("gobject-introspection" ,gobject-introspection)
-       ("pkg-config" ,pkg-config)))
+     (list `(,glib "bin")
+           gettext-minimal
+           gobject-introspection
+           pkg-config))
     (inputs
-     `(("clutter" ,clutter)
-       ("clutter-gst" ,clutter-gst)
-       ("clutter-gtk" ,clutter-gtk)
-       ("evince" ,evince)                         ; For file previewing.
-       ("freetype" ,freetype)
-       ("gdk-pixbuf" ,gdk-pixbuf)
-       ("gjs" ,gjs)
-       ("gst-plugins-base" ,gst-plugins-base)
-       ("gstreamer" ,gstreamer)
-       ("gtksourceview" ,gtksourceview)
-       ("harfbuzz" ,harfbuzz)
-       ("libepoxy" ,libepoxy)
-       ("libmusicbrainz" ,libmusicbrainz)
-       ("libxml2" ,libxml2)
-       ("neon" ,neon)
-       ("webkitgtk" ,webkitgtk)))
+     (list clutter
+           clutter-gst
+           clutter-gtk
+           evince                       ; For file previewing.
+           freetype
+           gdk-pixbuf
+           gjs
+           gst-plugins-base
+           gstreamer
+           gtksourceview
+           harfbuzz
+           libepoxy
+           libmusicbrainz
+           libxml2
+           neon
+           webkitgtk))
     (synopsis "File previewer for the GNOME desktop")
     (description "Sushi is a DBus-activated service that allows applications
 to preview files on the GNOME desktop.")