summary refs log tree commit diff
diff options
context:
space:
mode:
authorThomas Danckaert <thomas.danckaert@gmail.com>2017-08-22 19:25:11 +0200
committerThomas Danckaert <thomas.danckaert@gmail.com>2017-08-24 19:52:16 +0200
commit17e56dac127013a3bacefcf9bcbe13d27ce08055 (patch)
tree76888c43721a4e15629a4fff072faaafc2e60172
parent5cdb0cd3809277c9802e787432ca572e4f467a89 (diff)
downloadguix-17e56dac127013a3bacefcf9bcbe13d27ce08055.tar.gz
gnu: libreoffice: Fix icons, enable liblangtag.
* gnu/packages/libreoffice.scm (libreoffice) [inputs]: Add liblangtag.
  [arguments]: Correct icon names in .desktop files; copy desktop files &
  icons for libreoffice-math and libreoffice-startcenter; enable parallel
  build; enable liblangtag.
-rw-r--r--gnu/packages/libreoffice.scm23
1 files changed, 13 insertions, 10 deletions
diff --git a/gnu/packages/libreoffice.scm b/gnu/packages/libreoffice.scm
index 16a8d257d0..cca222b1f8 100644
--- a/gnu/packages/libreoffice.scm
+++ b/gnu/packages/libreoffice.scm
@@ -837,6 +837,7 @@ and to return information on pronunciations, meanings and synonyms.")
        ("libetonyek" ,libetonyek)
        ("libexttextcat" ,libexttextcat)
        ("libfreehand" ,libfreehand)
+       ("liblangtag" ,liblangtag)
        ("libmspub" ,libmspub)
        ("libmwaw" ,libmwaw)
        ("libodfgen" ,libodfgen)
@@ -919,15 +920,16 @@ and to return information on pronunciations, meanings and synonyms.")
                      (substitute* (string-append out src)
                        (("Exec=libreoffice[0-9]+\\.[0-9]+ ")
                         (string-append "Exec=" out "/bin/libreoffice "))
-                       (("Icon=libreoffice[0-9]+\\.[0-9]+")
-                        "Icon=libreoffice")
+                       (("Icon=libreoffice.*")
+                        (string-append "Icon=" app "\n"))
                        (("LibreOffice [0-9]+\\.[0-9]+")
                         "LibreOffice"))
-                     (symlink-output src dst)
-                     (install-file (string-append
+                     (symlink-output src dst)))
+                 (define (install-appdata app)
+                   (install-file (string-append
                                     "sysui/desktop/appstream-appdata/"
                                     "libreoffice-" app ".appdata.xml")
-                                   (string-append out "/share/appdata"))))
+                                   (string-append out "/share/appdata")))
                  (symlink-output "/lib/libreoffice/program/soffice"
                                  "/bin/soffice")
                  (symlink-output "/lib/libreoffice/program/soffice"
@@ -940,16 +942,18 @@ and to return information on pronunciations, meanings and synonyms.")
                   "workdir/CustomTarget/sysui/share/libreoffice/openoffice.org.xml"
                   "/share/mime/packages/libreoffice.xml")
                  (for-each install-desktop-file
+                           '("base" "calc" "draw" "impress" "writer"
+                             "math" "startcenter"))
+                 (for-each install-appdata
                            '("base" "calc" "draw" "impress" "writer"))
-                 (mkdir-p (string-append out "/share/icons"))
+                 (mkdir-p (string-append out "/share/icons/hicolor"))
                  (copy-recursively "sysui/desktop/icons/hicolor"
-                                   (string-append out "/share/icons/")))
+                                   (string-append out "/share/icons/hicolor")))
                #t)))
        #:configure-flags
         (list
           "--enable-release-build"
           "--enable-verbose"
-          "--without-parallelism" ; otherwise the build fails
           "--disable-fetch-external" ; disable downloads
           "--with-system-libs" ; enable all --with-system-* flags
           (string-append "--with-boost-libdir="
@@ -969,8 +973,7 @@ and to return information on pronunciations, meanings and synonyms.")
           "--disable-firebird-sdbc" ; embedded firebird
           "--disable-gltf"
           "--without-doxygen"
-          "--disable-gtk3"
-          "--disable-liblangtag")))
+          "--disable-gtk3")))
     (home-page "https://www.libreoffice.org/")
     (synopsis "Office suite")
     (description "LibreOffice is a comprehensive office suite.  It contains