summary refs log tree commit diff
diff options
context:
space:
mode:
authorkiasoc5 <kiasoc5@tutanota.com>2023-07-10 13:07:58 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-07-10 13:13:45 +0200
commit4181835a52c5af89aae9dfc422a4b22b1dbe7660 (patch)
treed212c34cf8f088cf7853e1f68a1e319df99bbcbf
parent8b38d180ec34cf60eb2659f662bba9d28190d20c (diff)
downloadguix-4181835a52c5af89aae9dfc422a4b22b1dbe7660.tar.gz
gnu: Add python-flask-compress.
* gnu/packages/python-web.scm (python-flask-compress): New variable.

Co-authored-by: Ricardo Wurmus <rekado@elephly.net>
-rw-r--r--gnu/packages/python-web.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index d0ac175039..8021eea830 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -3658,6 +3658,27 @@ and Jinja2 template engine.  It is called a micro framework because it does not
 presume or force a developer to use a particular tool or library.")
     (license license:bsd-3)))
 
+(define-public python-flask-compress
+  (package
+    (name "python-flask-compress")
+    (version "1.13")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "Flask-Compress" version))
+              (sha256
+               (base32
+                "178jzz6jxlxllcjqamzh5q7ahfh90m5cl1il9vmjs3xhz65z35pf"))))
+    (build-system pyproject-build-system)
+    (propagated-inputs (list python-brotli python-flask))
+    (native-inputs (list python-setuptools-scm))
+    (home-page "https://github.com/colour-science/flask-compress")
+    (synopsis "Compress responses in a Flask app")
+    (description
+     "This package lets you compress Flask application responses and static
+files with gzip, deflate or brotli.  Flask-Compress both adds the various
+headers required for a compressed response and compresses the response data.")
+    (license license:expat)))
+
 (define-public python-flask-wtf
   (package
     (name "python-flask-wtf")