summary refs log tree commit diff
diff options
context:
space:
mode:
authorraingloom <raingloom@riseup.net>2023-02-15 23:00:03 +0100
committerChristopher Baines <mail@cbaines.net>2023-02-17 15:44:55 +0000
commit74560bf3c3b1f373f2d10f71042beb97680f34f9 (patch)
tree59ded6cd18e72153f96cd3da41d9985152dcda99
parent14ccbf500cfac3162938b5901c7fde87cba5e39b (diff)
downloadguix-74560bf3c3b1f373f2d10f71042beb97680f34f9.tar.gz
gnu: Add aliases for ocaml-cstruct and ocaml-lwt subpackages.
* gnu/packages/ocaml.scm (ocaml-lwt-ppx ocaml-cstruct-unix
  ocaml-cstruct-sexp): New variables.

Signed-off-by: Christopher Baines <mail@cbaines.net>
-rw-r--r--gnu/packages/ocaml.scm11
1 files changed, 11 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 6abd38e1ad..9069b320e9 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -2963,6 +2963,11 @@ process.  Also, in many cases, Lwt threads can interact without the need for
 locks or other synchronization primitives.")
     (license license:lgpl2.1)))
 
+;; TODO this alias is not ideal but ocaml-lwt already explicitly specifies a
+;; package argument and at least this way the importer doesn't try to
+;; re-import it.
+(define ocaml-lwt-ppx ocaml-lwt)
+
 (define-public ocaml-lwt-dllist
   (package
     (name "ocaml-lwt-dllist")
@@ -4451,6 +4456,12 @@ writing to these structures, and they are accessed via the Bigarray module.")
                   "0jj3whs8r3jc524i9bb67rffh7y7r157hjgvws0bkxijxpjzwkbk"))))
       (properties '()))))
 
+;; TODO again, the "parent" package already has an explicit package argument,
+;; so a variant package doesn't make sense, at least these aliases help the
+;; importer out so it doesn't re-import things.  At least hopefully.
+(define ocaml-cstruct-unix ocaml-cstruct)
+(define ocaml-cstruct-sexp ocaml-cstruct)
+
 (define-public ocaml-hex
   (package
     (name "ocaml-hex")