summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2017-07-25 04:51:35 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2017-07-26 19:38:59 +0200
commit9d9fc399463ea1371fff37320774a99d66d7eb2b (patch)
treea7522dab6b0d155c9bd87eceacdc9cb6cbaae22d
parentf96dbf6b70364518072c63037d3fca105dfe6497 (diff)
downloadguix-9d9fc399463ea1371fff37320774a99d66d7eb2b.tar.gz
gnu: Add lziprecover.
* gnu/packages/compression.scm (lziprecover): New variable.
-rw-r--r--gnu/packages/compression.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/compression.scm b/gnu/packages/compression.scm
index ede35f9f5b..92636de7fe 100644
--- a/gnu/packages/compression.scm
+++ b/gnu/packages/compression.scm
@@ -480,6 +480,36 @@ more than bzip2, which makes it well suited for software distribution and data
 archiving.  Lzip is a clean implementation of the LZMA algorithm.")
     (license license:gpl3+)))
 
+(define-public lziprecover
+  (package
+    (name "lziprecover")
+    (version "1.19")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "mirror://savannah/lzip/" name "/"
+                                  name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "0z5fbkm0qprypjf7kxkqganniibj0zml13zvfkrchnjafcmmzyld"))))
+    (build-system gnu-build-system)
+    (home-page "http://www.nongnu.org/lzip/lziprecover.html")
+    (synopsis "Recover and decompress data from damaged lzip files")
+    (description
+     "Lziprecover is a data recovery tool and decompressor for files in the lzip
+compressed data format (.lz).  It can test the integrity of lzip files, extract
+data from damaged ones, and repair most files with small errors (up to one
+single-byte error per member) entirely.
+
+Lziprecover is not a replacement for regular backups, but a last line of defence
+when even the backups are corrupt.  It can recover files by merging the good
+parts of two or more damaged copies, such as can be easily produced by running
+@command{ddrescue} on a failing device.
+
+This package also includes @command{unzcrash}, a tool to test the robustness of
+decompressors when faced with corrupted input.")
+    (license (list license:bsd-2        ; arg_parser.{cc,h}
+                   license:gpl2+))))    ; everything else
+
 (define-public sharutils
   (package
     (name "sharutils")