summary refs log tree commit diff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-07-11 15:06:19 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-07-11 15:06:19 -0400
commitdf44d359f368e17e87f73a23694fab43e5d0f6ab (patch)
tree38a65a6057b0d00356fca8bd108357108dd3d414
parent85d7babe64b49974f3edc6f4ee81fa8d33f0f087 (diff)
downloadguix-df44d359f368e17e87f73a23694fab43e5d0f6ab.tar.gz
gnu: luit: Fix invalid locale.alias location.
Fixes <https://issues.guix.gnu.org/43592>.

* gnu/packages/xorg.scm (mkfontscale)[configure-flags]: Point to libx11's
locale.alias file via the '--with-localealiasfile' configure option.
[inputs]{libx11}: New input.
-rw-r--r--gnu/packages/xorg.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 35bcbead39..d44bd52f54 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -1548,8 +1548,14 @@ treat it as part of their software base when porting.")
        ;; should become obsolete with the next release.
        (patches (search-patches "luit-posix.patch"))))
     (build-system gnu-build-system)
+    (arguments
+     (list
+      #:configure-flags
+      #~(list (string-append "--with-localealiasfile="
+                             (search-input-file
+                              %build-inputs "share/X11/locale/locale.alias")))))
     (inputs
-     (list libfontenc))
+     (list libfontenc libx11))
     (native-inputs
      (list pkg-config))
     (home-page "https://www.x.org/wiki/")