summary refs log tree commit diff
diff options
context:
space:
mode:
authorAhmad Draidi <a.r.draidi@redscript.org>2023-07-10 14:31:06 +0400
committerAndrew Tropin <andrew@trop.in>2023-07-11 20:06:11 +0400
commitebaeeacc840eb48dc29e6a9630289790fd4394dc (patch)
treedc9635f17ee82828e8bee396defb4ee0560b3448
parent3b77a06f3b2e4b3a78b8894d0349af316ae10ef4 (diff)
downloadguix-ebaeeacc840eb48dc29e6a9630289790fd4394dc.tar.gz
gnu: Add emacs-abyss-theme.
* gnu/packages/emacs-xyz.scm (emacs-abyss-theme): New variable.

Signed-off-by: Andrew Tropin <andrew@trop.in>
-rw-r--r--gnu/packages/emacs-xyz.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index a2fbb7069f..154d4d1370 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -2616,6 +2616,30 @@ can take association lists, hash tables, and in some cases vectors (where the
 index is considered the key).")
     (license license:gpl3+)))
 
+(define-public emacs-abyss-theme
+  (package
+    (name "emacs-abyss-theme")
+    (version "0.7")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/mgrbyte/emacs-abyss-theme")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "07z0djv7h3yrv4iw9n633j6dxzxb4nnzijsqkmz22ik6fbwxg5mh"))))
+    (build-system emacs-build-system)
+    (home-page "https://github.com/mgrbyte/emacs-abyss-theme")
+    (synopsis "Dark theme with strong colours for Emacs")
+    (description
+     "A dark theme with contrasting colours for Emacs based on the
+@url{https://github.com/andre-richter/emacs-lush-theme, @code{lush}} theme by
+Andre Richter, using the same colours palette as the the built-in
+@code{dichromacy} theme; intended to be suitable
+for red/green colour blind users.")
+    (license license:gpl3+)))
+
 (define-public emacs-ace-jump-mode
   (package
     (name "emacs-ace-jump-mode")