summary refs log tree commit diff
diff options
context:
space:
mode:
authorTimotej Lazar <timotej.lazar@araneo.si>2023-06-24 13:28:04 +0200
committerLudovic Courtès <ludo@gnu.org>2023-07-11 16:06:51 +0200
commitf969f45fa8ad8922b1020c93a8fc4d83064c88ae (patch)
tree5c40805c20e1cc7e6e1674fb28c63af83804aa60
parentf0dfb2a8e98babcdfa13937843bf19abfe149d6e (diff)
downloadguix-f969f45fa8ad8922b1020c93a8fc4d83064c88ae.tar.gz
gnu: rxvt-unicode: Use new package style.
* gnu/packages/xdisorg.scm (rxvt-unicode)[arguments]: Use gexps.
[inputs]: Drop input labels.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/xdisorg.scm78
1 files changed, 35 insertions, 43 deletions
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 5d3a2961d0..4d072d1e16 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -1285,52 +1285,44 @@ compact configuration syntax.")
      ;; This sets the destination when installing the necessary terminal
      ;; capability data, which are not provided by 'ncurses'.  See
      ;; https://lists.gnu.org/archive/html/bug-ncurses/2009-10/msg00031.html
-     `(#:configure-flags (list "--enable-256-color")
-       #:make-flags (list (string-append "TERMINFO="
-                                         (assoc-ref %outputs "out")
-                                         "/share/terminfo"))
-       #:phases
-       (modify-phases %standard-phases
-         (add-after 'install 'install-desktop-urxvt
-           (lambda* (#:key outputs #:allow-other-keys)
-             (let* ((output (assoc-ref outputs "out"))
-                    (desktop (string-append output "/share/applications")))
-               (mkdir-p desktop)
-               (with-output-to-file
-                   (string-append desktop "/urxvt.desktop")
+     (list #:configure-flags #~(list "--enable-256-color")
+           #:make-flags #~(list (string-append "TERMINFO=" #$output "/share/terminfo"))
+           #:phases
+           #~(modify-phases %standard-phases
+               (add-after 'install 'install-desktop-urxvt
                  (lambda _
-                   (format #t
-                           "[Desktop Entry]~@
-                           Name=rxvt-unicode~@
-                           Comment=~@
-                           Exec=~a/bin/urxvt~@
-                           TryExec=~@*~a/bin/urxvt~@
-                           Icon=~@
-                           Type=Application~%"
-                           output))))))
-         (add-after 'install 'install-desktop-urxvtc
-           (lambda* (#:key outputs #:allow-other-keys)
-             (let* ((output (assoc-ref outputs "out"))
-                    (desktop (string-append output "/share/applications")))
-               (mkdir-p desktop)
-               (with-output-to-file
-                   (string-append desktop "/urxvtc.desktop")
+                   (let ((desktop (string-append #$output "/share/applications")))
+                     (mkdir-p desktop)
+                     (with-output-to-file
+                         (string-append desktop "/urxvt.desktop")
+                       (lambda _
+                         (format #t
+                                 "[Desktop Entry]~@
+                                 Name=rxvt-unicode~@
+                                 Comment=~@
+                                 Exec=~a/bin/urxvt~@
+                                 TryExec=~@*~a/bin/urxvt~@
+                                 Icon=~@
+                                 Type=Application~%"
+                                 #$output))))))
+               (add-after 'install 'install-desktop-urxvtc
                  (lambda _
-                   (format #t
-                           "[Desktop Entry]~@
-                           Name=rxvt-unicode (client)~@
-                           Comment=Rxvt clone with XFT and unicode support~@
-                           Exec=~a/bin/urxvtc~@
-                           TryExec=~@*~a/bin/urxvtc~@
-                           Icon=~@
-                           Type=Application~%"
-                           output)))))))))
+                   (let ((desktop (string-append #$output "/share/applications")))
+                     (mkdir-p desktop)
+                     (with-output-to-file
+                         (string-append desktop "/urxvtc.desktop")
+                       (lambda _
+                         (format #t
+                                 "[Desktop Entry]~@
+                                 Name=rxvt-unicode (client)~@
+                                 Comment=Rxvt clone with XFT and unicode support~@
+                                 Exec=~a/bin/urxvtc~@
+                                 TryExec=~@*~a/bin/urxvtc~@
+                                 Icon=~@
+                                 Type=Application~%"
+                                 #$output)))))))))
     (inputs
-     `(("libptytty" ,libptytty)
-       ("libXft" ,libxft)
-       ("libX11" ,libx11)
-       ("libXt" ,libxt)
-       ("libxext" ,libxext)))
+     (list libptytty libxft libx11 libxt libxext))
     (native-inputs
      (list ncurses ;trigger the installation of terminfo data
            perl pkg-config))