summary refs log tree commit diff
diff options
context:
space:
mode:
authorLudovic Courtès <ludovic.courtes@inria.fr>2017-06-15 15:47:32 +0200
committerLudovic Courtès <ludo@gnu.org>2017-06-15 23:07:46 +0200
commit02084762605e1fd8bc70376e4297871db6d84a82 (patch)
treee4f425e26c75707ea44f22f138287eb09f22a30d
parente50c8aadae75486c91cfc21b09721a6b6509c5e2 (diff)
downloadguix-02084762605e1fd8bc70376e4297871db6d84a82.tar.gz
gnu: proot: Install man page under the right name.
* gnu/packages/linux.scm (proot)[arguments]: In 'install' phase, install
man page as "proot.1", not "man.1".
-rw-r--r--gnu/packages/linux.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index f4f5d50543..cf37afe682 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -3964,10 +3964,11 @@ userspace queueing component and the logging subsystem.")
                               ;; build currently.)
                               (system* "make" "-C" "src" "install"
                                        (string-append "PREFIX=" out)))
-                             (begin
-                               (install-file "doc/proot/man.1"
-                                             (string-append out "/share"
-                                                            "/man/man1"))
+                             (let ((man1 (string-append out
+                                                        "/share/man/man1")))
+                               (mkdir-p man1)
+                               (copy-file "doc/proot/man.1"
+                                          (string-append man1 "/proot.1"))
                                #t))))))))
     (native-inputs `(("which" ,which)