summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 13:10:51 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 19:41:17 +0200
commit023332f69eb77d1f3769ef3fef78a864afe7fada (patch)
tree993b2acd8b925282096b57fd1f62b49c1ad40208
parent5138207b6a58d7cb8b1e18a373bc49229f1f0aff (diff)
downloadguix-023332f69eb77d1f3769ef3fef78a864afe7fada.tar.gz
gnu: Add texlive-chemarrow.
* gnu/packages/tex.scm (texlive-chemarrow): New variable.
-rw-r--r--gnu/packages/tex.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 6753eff826..451b01fe4e 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -2226,6 +2226,34 @@ parameter value for style, another for a property).  User input to
 documents sharing the same notation.")
     (license license:lppl1.3c)))
 
+(define-public texlive-chemarrow
+  (package
+    (name "texlive-chemarrow")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/fonts/chemarrow/"
+                   "fonts/afm/public/chemarrow/"
+                   "fonts/map/dvips/chemarrow/"
+                   "fonts/source/public/chemarrow/"
+                   "fonts/tfm/public/chemarrow/"
+                   "fonts/type1/public/chemarrow/"
+                   "source/fonts/chemarrow/"
+                   "tex/latex/chemarrow/")
+             (base32
+              "1ky0v2psxamzilmijih88zxanmq2hnpv1yc18mcy9mpymcmvrhwr")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (native-inputs (list texlive-metafont))
+    (home-page "https://ctan.org/pkg/chemarrow")
+    (synopsis "Arrows for use in chemistry")
+    (description
+     "This bundle consists of a font (available as Metafont source, MetaPost
+source, and generated type 1 versions), and a package to use it.  The arrows
+in the font are designed to look more like those in chemistry text-books than
+do Knuth's originals.")
+    (license license:public-domain)))
+
 (define-public texlive-chronosys
   (package
     (name "texlive-chronosys")