summary refs log tree commit diff
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2017-02-11 21:32:20 -0600
committerEric Bavier <bavier@member.fsf.org>2017-02-13 22:28:32 -0600
commit02a7a0caf4d159017755b9298f2f699fb0f46f46 (patch)
tree1a3598e7923dff7d40ad1fe7172c6da4caf6a02f
parent54b7f14956d0f5248bb62ead02ae0165c0320921 (diff)
downloadguix-02a7a0caf4d159017755b9298f2f699fb0f46f46.tar.gz
gnu: Add libnspsl.
* gnu/packages/web.scm (libnspsl): New variable.
-rw-r--r--gnu/packages/web.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index e858888b40..ffd3c11e21 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -4013,6 +4013,29 @@ C.  It is developed as part of the NetSurf project.")
 developed as part of the NetSurf project.")
     (license l:expat)))
 
+(define-public libnspsl
+  (package
+    (name "libnspsl")
+    (version "0.1.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "http://download.netsurf-browser.org/libs/releases/"
+                           name "-" version "-src.tar.gz"))
+       (sha256
+        (base32
+         "0x3frscrp9bzxlm9ama5laxjr3zi8cg20r8lhsamw4x4zyyk145y"))))
+    (build-system gnu-build-system)
+    (native-inputs
+     `(("netsurf-buildsystem" ,netsurf-buildsystem)))
+    (arguments netsurf-buildsystem-arguments)
+    (home-page "http://www.netsurf-browser.org/")
+    (synopsis "Library to generate a static Public Suffix List")
+    (description
+     "Libnspsl is a library to generate a static code representation of the
+Public Suffix List.  It is developed as part of the NetSurf project.")
+    (license l:expat)))
+
 (define-public netsurf
   (package
     (name "netsurf")