summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-03-19 20:29:46 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2018-05-01 07:13:49 +0200
commit02fcc6f240946cfd51bfe548e260b2f3150f0ab4 (patch)
tree0996e5f744e8410ef090c573233d8dd75092c382
parenteb6a5dab5cf0f85fbc4eda4b6f7956eed464c3cf (diff)
downloadguix-02fcc6f240946cfd51bfe548e260b2f3150f0ab4.tar.gz
gnu: zathura-cb: Update to 0.1.8.
* gnu/packages/pdf.scm (zathura-cb): Update to 0.1.8.
[build-system]: Switch to the Meson build system.
[arguments]: Trim accordingly.  Add a new ‘patch-plugin-directory’
phase.
-rw-r--r--gnu/packages/pdf.scm24
1 files changed, 15 insertions, 9 deletions
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index 633a344022..1054bc2fda 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -314,26 +314,32 @@ reading and editing of existing PDF files.")
 (define-public zathura-cb
   (package
     (name "zathura-cb")
-    (version "0.1.7")
+    (version "0.1.8")
     (source (origin
               (method url-fetch)
               (uri
                (string-append "https://pwmt.org/projects/zathura-cb/download/zathura-cb-"
-                              version ".tar.gz"))
+                              version ".tar.xz"))
               (sha256
                (base32
-                "0r4viisycj39kaz4281cmkr7n9w5q96dmlf7nf45n8zq8qy2npw3"))))
+                "1i6cf0vks501cggwvfsl6qb7mdaf3sszdymphimfvnspw810faj5"))))
     (native-inputs `(("pkg-config" ,pkg-config)))
     (inputs `(("libarchive" ,libarchive)
               ("zathura" ,zathura)))
-    (build-system gnu-build-system)
+    (build-system meson-build-system)
     (arguments
-     `(#:make-flags (list (string-append "PREFIX=" %output)
-                          (string-append "PLUGINDIR=" %output "/lib/zathura")
-                          "CC=gcc")
-       #:tests? #f ; Package does not contain tests.
+     `(#:tests? #f                      ; package does not contain tests
        #:phases
-       (modify-phases %standard-phases (delete 'configure))))
+       (modify-phases %standard-phases
+         (add-after 'unpack 'patch-plugin-directory
+           ;; Something of a regression in 0.1.8: the new Meson build system
+           ;; now hard-codes an incorrect plugin directory.  Fix it.
+           (lambda* (#:key outputs #:allow-other-keys)
+             (substitute* "meson.build"
+               (("(install_dir:).*" _ key)
+                (string-append key
+                               "'" (assoc-ref outputs "out") "/lib/zathura'\n")))
+             #t)))))
     (home-page "https://pwmt.org/projects/zathura-cb/")
     (synopsis "Comic book support for zathura (libarchive backend)")
     (description "The zathura-cb plugin adds comic book support to zathura