summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-07-12 16:29:33 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-07-12 17:21:16 +0200
commit041f84edf3a91834026d85f4a3829fdeaa6c7311 (patch)
tree0383ebf235ac273d19616d340b9d99d809109c62
parentb7a2d2d9a91f6f1a680ef5dbcab4268102d1e1c7 (diff)
downloadguix-041f84edf3a91834026d85f4a3829fdeaa6c7311.tar.gz
gnu: ldb: Downgrade to 1.3.3.
LDB 1.4 and above does not support Samba < 4.9; see
<https://bugzilla.samba.org/show_bug.cgi?id=13519>.

* gnu/packages/samba.scm (ldb): Downgrade to 1.3.3.
[inputs]: Remove LMDB.
[arguments]: Remove #:tests.
-rw-r--r--gnu/packages/samba.scm14
1 files changed, 4 insertions, 10 deletions
diff --git a/gnu/packages/samba.scm b/gnu/packages/samba.scm
index f81c586186..64017224a7 100644
--- a/gnu/packages/samba.scm
+++ b/gnu/packages/samba.scm
@@ -341,14 +341,14 @@ many event types, including timers, signals, and the classic file descriptor eve
 (define-public ldb
   (package
     (name "ldb")
-    (version "1.4.0")
+    (version "1.3.3")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://www.samba.org/ftp/ldb/ldb-"
                                   version ".tar.gz"))
               (sha256
                (base32
-                "1d591ny4j4s409s2afjv4fn7inqlclr0zlyclw3619rkbaixlzm8"))
+                "14gsrm7dvyjpbpnc60z75j6fz2p187abm2h353lq95kx2bv70c1b"))
               (modules '((guix build utils)))
               (snippet
                '(begin
@@ -361,10 +361,7 @@ many event types, including timers, signals, and the classic file descriptor eve
                   #t))))
     (build-system gnu-build-system)
     (arguments
-     '(;; LMDB is only supported on 64-bit systems, yet the test suite
-       ;; requires it.
-       #:tests? (assoc-ref %build-inputs "lmdb")
-       #:phases
+     '(#:phases
        (modify-phases %standard-phases
          (replace 'configure
            ;; ldb use a custom configuration script that runs waf.
@@ -384,10 +381,7 @@ many event types, including timers, signals, and the classic file descriptor eve
      `(("talloc" ,talloc)
        ("tdb" ,tdb)))
     (inputs
-     `(,@(if (target-64bit?)
-             `(("lmdb" ,lmdb))
-             '())
-       ("popt" ,popt)
+     `(("popt" ,popt)
        ("tevent" ,tevent)))
     (synopsis "LDAP-like embedded database")
     (home-page "https://ldb.samba.org/")