summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-09-23 17:37:53 +0300
committerEfraim Flashner <efraim@flashner.co.il>2016-09-23 17:38:25 +0300
commit047cd01d11539b4afc547e430ae7f3b9af976bea (patch)
tree65ff84f060e3ddd0afee697787dfbc26b5e058ad
parent5bd6270211b8b4d9335960eb5741c34308187ccd (diff)
downloadguix-047cd01d11539b4afc547e430ae7f3b9af976bea.tar.gz
gnu: orpheus: Use 'modify-phases'.
* gnu/packages/orpheus.scm (orpheus)[arguments]: Use the 'modify-phases'
syntax.
-rw-r--r--gnu/packages/orpheus.scm79
1 files changed, 39 insertions, 40 deletions
diff --git a/gnu/packages/orpheus.scm b/gnu/packages/orpheus.scm
index f7912524c2..39118c9abc 100644
--- a/gnu/packages/orpheus.scm
+++ b/gnu/packages/orpheus.scm
@@ -53,46 +53,45 @@
        ("which" ,which)))
     (arguments
      `(#:phases
-       (alist-replace
-        'configure
-        (lambda* (#:key outputs #:allow-other-keys)
-          ;; This old `configure' script does not support variables passed as
-          ;; arguments.
-          (let ((out (assoc-ref outputs "out")))
-            (setenv "CONFIG_SHELL" (which "bash"))
-            (setenv "SHELL" (which "bash"))
-            (setenv "LIBS" "-logg")     ;doesn't declare its use of libogg
-            (zero?
-             (system* "./configure" (string-append "--prefix=" out)
-                                    ,@(if (string=? "mips64el-linux"
-                                                    (%current-system))
-                                          '("--host=mips64el-unknown-linux-gnu")
-                                          '())
-                      ))))
-        (alist-cons-after
-         'configure 'configure-players
-         (lambda* (#:key inputs #:allow-other-keys)
-           ;; To avoid propagating the mpg321 and vorbis-tools inputs, we can
-           ;; make the orpheus application execute the needed players from the
-           ;; store.
-           (let ((ogg123 (string-append (assoc-ref inputs "vorbis-tools")
-                                        "/bin/ogg123"))
-                 (mpg321 (string-append (assoc-ref inputs "mpg321")
-                                        "/bin/mpg321"))
-                 (which  (string-append (assoc-ref inputs "which")
-                                        "/bin/which")))
-             (substitute* "src/orpheusconf.cc"
-               (("ogg123") ogg123)
-               (("which")  which)
-               (("mpg321") mpg321))))
-         (alist-cons-before
-          'build 'patch-shells
-          (lambda _
-            (substitute* '("src/mp3track.cc"
-                           "src/streamtrack.cc"
-                           "src/oggtrack.cc")
-              (("/bin/sh") (which "bash"))))
-          %standard-phases)))))
+       (modify-phases %standard-phases
+         (replace 'configure
+           (lambda* (#:key outputs #:allow-other-keys)
+             ;; This old `configure' script does not support variables passed as
+             ;; arguments.
+             (let ((out (assoc-ref outputs "out")))
+               (setenv "CONFIG_SHELL" (which "bash"))
+               (setenv "SHELL" (which "bash"))
+               (setenv "LIBS" "-logg")     ;doesn't declare its use of libogg
+               (zero?
+                (system* "./configure" (string-append "--prefix=" out)
+                                       ,@(if (string=? "mips64el-linux"
+                                                       (%current-system))
+                                             '("--host=mips64el-unknown-linux-gnu")
+                                             '())
+                         )))))
+         (add-after 'configure 'configure-players
+           (lambda* (#:key inputs #:allow-other-keys)
+             ;; To avoid propagating the mpg321 and vorbis-tools inputs, we can
+             ;; make the orpheus application execute the needed players from the
+             ;; store.
+             (let ((ogg123 (string-append (assoc-ref inputs "vorbis-tools")
+                                          "/bin/ogg123"))
+                   (mpg321 (string-append (assoc-ref inputs "mpg321")
+                                          "/bin/mpg321"))
+                   (which  (string-append (assoc-ref inputs "which")
+                                          "/bin/which")))
+               (substitute* "src/orpheusconf.cc"
+                 (("ogg123") ogg123)
+                 (("which")  which)
+                 (("mpg321") mpg321))
+               #t)))
+         (add-before 'build 'patch-shells
+           (lambda _
+             (substitute* '("src/mp3track.cc"
+                            "src/streamtrack.cc"
+                            "src/oggtrack.cc")
+               (("/bin/sh") (which "bash")))
+             #t)))))
     (home-page "http://thekonst.net/en/orpheus")
     (synopsis "Text-mode audio player")
     (description