summary refs log tree commit diff
diff options
context:
space:
mode:
authorMădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>2019-12-17 18:24:35 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-12-19 00:01:49 +0100
commit073723fa9a60dc8421223fcd2f54d265027b3806 (patch)
treed3aed3530ad056f27b28d7b295e9e8d191e32b1c
parentfcc4e9e7f7cb63b93f953038bc5f57039af69971 (diff)
downloadguix-073723fa9a60dc8421223fcd2f54d265027b3806.tar.gz
gnu: Add python-ppft.
* gnu/packages/python-xyz.scm (python-ppft): New variable.

Co-authored-by: Ricardo Wurmus <rekado@elephly.net>
-rw-r--r--gnu/packages/python-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 1718758721..25c6f9c0a5 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -16909,3 +16909,28 @@ always possible to declare a command with the highest possible (and least
 flexible) layer and then tune the behaviour with any of the lower layers
 including the native API of @code{python-argparse}.")
       (license license:lgpl3+))))
+
+(define-public python-ppft
+  (package
+    (name "python-ppft")
+    (version "1.6.6.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "ppft" version))
+       (sha256
+        (base32
+         "1z1invkhszc5d2mvgr221v7cszzifcc77mz0pv3wjp6x5q2768cy"))))
+    (build-system python-build-system)
+    (arguments '(#:tests? #f))          ; there are none
+    (propagated-inputs
+     `(("python-six" ,python-six)))
+    (home-page "https://pypi.org/project/ppft/")
+    (synopsis "Fork of Parallel Python")
+    (description
+     "This package is a fork of Parallel Python.  The Parallel Python
+module (@code{pp}) provides an easy and efficient way to create
+parallel-enabled applications for @dfn{symmetric multiprocessing} (SMP)
+computers and clusters.  It features cross-platform portability and dynamic
+load balancing.")
+    (license license:bsd-3)))