summary refs log tree commit diff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2016-12-30 11:50:19 +0100
committerJulien Lepiller <julien@lepiller.eu>2017-01-16 22:34:45 +0100
commit0a7b43a8187f8f374ab1a696fedf182679a5ae65 (patch)
treee09b625f7454e72240ad1739eeb281efe7ef6af5
parent69705efe9414c1964bcab7c214688ca153529385 (diff)
downloadguix-0a7b43a8187f8f374ab1a696fedf182679a5ae65.tar.gz
gnu: Add ocaml-ppx-tools.
* gnu/packages/ocaml.scm (ocaml-ppx-tools): New variable.
-rw-r--r--gnu/packages/ocaml.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index cfe2eb1dac..16d56febd1 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -1316,3 +1316,22 @@ Alcotest provides a quiet and colorful output where only faulty runs are fully
 displayed at the end of the run (with the full logs ready to inspect), with a
 simple (yet expressive) query language to select the tests to run.")
     (license license:isc)))
+
+(define-public ocaml-ppx-tools
+  (package
+    (name "ocaml-ppx-tools")
+    (version "5.0+4.02.0")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (string-append "https://github.com/alainfrisch/ppx_tools/archive/"
+                            version ".tar.gz"))
+        (sha256 (base32
+                  "0rjg4rngi8k9873z4zq95zn9hj8qyw1vcrf11y15aqasfpqq16rc"))))
+    (build-system ocaml-build-system)
+    (arguments `(#:phases (modify-phases %standard-phases (delete 'configure))
+                 #:tests? #f))
+    (home-page "https://github.com/alainfrisch/ppx_tools")
+    (synopsis "Tools for authors of ppx rewriters and other syntactic tools")
+    (description "Tools for authors of ppx rewriters and other syntactic tools.")
+    (license license:expat)))