summary refs log tree commit diff
diff options
context:
space:
mode:
authorSimon Streit <simon@netpanic.org>2023-03-11 23:10:15 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-03-17 09:22:50 +0100
commit0c2eef25c5fcc2d9246c85bee9da9f4c83e96cae (patch)
treeeb9241842b2686ccae368b46f72dfc86bdb2d5fe
parent156aac1b36c674ebcaf8876f40815ce56fa90662 (diff)
downloadguix-0c2eef25c5fcc2d9246c85bee9da9f4c83e96cae.tar.gz
gnu: emacs-bash-completion: Update to 3.1.1-1.b38f9bc.
* gnu/packages/emacs-xyz.scm (emacs-bash-completion): Update to
3.1.1-1.b38f9bc.

Fix an issue <https://github.com/szermatt/emacs-bash-completion/issues/63>
where in a new shell completion would break and cancel the whole shell process
with it.

Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/emacs-xyz.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 68bac3121b..608db8068a 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -19707,11 +19707,11 @@ Slack client.")
       (license license:gpl3+))))
 
 (define-public emacs-bash-completion
-  ;; This commit includes unreleased fixes that make using completion inside
-  ;; 'guix shell' possible (see:
-  ;; https://github.com/szermatt/emacs-bash-completion/issues/62).
-  (let ((commit "796a806c5531fc20afea590ba3c1d8a42fb793fc")
-        (revision "0"))
+  ;; This commit fixes an issue that would brake the shell process if trying
+  ;; to complete a command (see:
+  ;; https://github.com/szermatt/emacs-bash-completion/issues/63).
+  (let ((commit "b38f9bca0c194ee3a79c19a14db3b38d1262ca8c")
+        (revision "1"))
     (package
       (name "emacs-bash-completion")
       (version (git-version "3.1.1" revision commit))
@@ -19723,7 +19723,7 @@ Slack client.")
                (commit commit)))
          (file-name (git-file-name name version))
          (sha256
-          (base32 "13mdb5arifkwghdclvp23q336n49x2hgqnll7m1lg3nh6jgq8jvk"))))
+          (base32 "09didsy8l6q083djlf9xqqx4fbsisaq5j7vj8fj4qlwh34pfl94c"))))
       (build-system emacs-build-system)
       (arguments
        (list