summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-12-27 21:46:46 +0100
committerMarius Bakke <marius@gnu.org>2022-12-28 00:38:41 +0100
commit0cb8f7125b19264b01962c1249c3df4c5ce85aa9 (patch)
tree114c5c6e4151ccea794fa0c5f6db36cc865050dc
parent7e6901618f7a4b9539d0e18ab24876126803b0e0 (diff)
downloadguix-0cb8f7125b19264b01962c1249c3df4c5ce85aa9.tar.gz
gnu: python-bitarray: Update to 2.6.1.
* gnu/packages/python-xyz.scm (python-bitarray): Update to 2.6.1.
[arguments]: Override check phase.
-rw-r--r--gnu/packages/python-xyz.scm14
1 files changed, 12 insertions, 2 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 6b71d6872e..d0cedf696a 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -1675,14 +1675,24 @@ and a list of words that are easier to remember for humans (the
 (define-public python-bitarray
   (package
     (name "python-bitarray")
-    (version "1.4.0")
+    (version "2.6.1")
     (source (origin
               (method url-fetch)
               (uri (pypi-uri "bitarray" version))
               (sha256
                (base32
-                "177fj6wbw5jln54wpp6plcqy2329wjkwqwvgz7022rrg3xfrq49g"))))
+                "0c4jli872nzix81n1xirnrghlq2fdsxb570d9rnfvxi1694sah44"))))
     (build-system python-build-system)
+    (arguments
+     (list #:phases
+           #~(modify-phases %standard-phases
+               (replace 'check
+                 (lambda* (#:key tests? #:allow-other-keys)
+                   (when tests?
+                     ;; Step out of the source directory to avoid interference.
+                     (with-directory-excursion "/tmp"
+                       (invoke "python" "-c"
+                               "import bitarray; bitarray.test()"))))))))
     (home-page "https://github.com/ilanschnell/bitarray")
     (synopsis "Efficient arrays of booleans")
     (description "This package provides an object type which efficiently