summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2016-09-21 22:45:28 +0200
committerRicardo Wurmus <rekado@elephly.net>2016-09-26 03:24:55 +0200
commit0d90462fa322201e3a59621e959afa9d5aaf0173 (patch)
tree3251ccc341df45f4af4a48649044a2cf9109c993
parent8e1bfc7e8c5292cfe04a06732bc11cf03777247f (diff)
downloadguix-0d90462fa322201e3a59621e959afa9d5aaf0173.tar.gz
gnu: Add r-backports.
* gnu/packages/statistics.scm (r-backports): New variable.
-rw-r--r--gnu/packages/statistics.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index d05dfce907..c3dadbdf60 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -1610,6 +1610,29 @@ previous R versions and their release dates.")
 limited to R.")
     (license license:gpl3+)))
 
+(define-public r-backports
+  (package
+    (name "r-backports")
+    (version "1.0.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "backports" version))
+       (sha256
+        (base32
+         "0s04mbb7imqc00jl37i081y4yf7qdimk687dyrkvb20nixvjvjyh"))))
+    (build-system r-build-system)
+    (home-page "http://cran.r-project.org/web/packages/backports")
+    (synopsis "Reimplementations of functions introduced since R 3.0.0")
+    (description
+     "Provides implementations of functions which have been introduced in R
+since version 3.0.0.  The backports are conditionally exported which results
+in R resolving the function names to the version shipped with R (if available)
+and uses the implemented backports as fallback.  This way package developers
+can make use of the new functions without worrying about the minimum required
+R version.")
+    (license license:gpl2+)))
+
 (define-public r-brew
   (package
     (name "r-brew")