summary refs log tree commit diff
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2017-04-12 01:22:45 +0530
committerArun Isaac <arunisaac@systemreboot.net>2017-04-12 18:55:51 +0530
commit0ee59b81c739d08863363e7f901e130135617b23 (patch)
treea8c9c9963d7e04703a2b8d056a3b5ef1d79327cd
parenta7a4345de12725b4e4d349e037d5de6b5dc93b1d (diff)
downloadguix-0ee59b81c739d08863363e7f901e130135617b23.tar.gz
gnu: Add emacs-xmlgen.
* gnu/packages/emacs.scm (emacs-xmlgen): New variable.
-rw-r--r--gnu/packages/emacs.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 532c1ce618..741b01e558 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -4278,3 +4278,33 @@ source file, @file{jl-encrypt.el}.")
 the associated decorations to HTML.  Output to CSS, inline CSS and
 fonts is supported.")
     (license license:gpl2+)))
+
+(define-public emacs-xmlgen
+  (package
+    (name "emacs-xmlgen")
+    (version "0.5")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://github.com/philjackson/xmlgen/archive/"
+             version ".tar.gz"))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "0zay490vjby3f7455r0vydmjg7q1gwc78hilpfb0rg4gwz224z8r"))))
+    (build-system emacs-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-before 'install 'check
+           (lambda _
+             (zero? (system* "emacs" "--batch" "-L" "."
+                             "-l" "xmlgen-test.el"
+                             "-f" "ert-run-tests-batch-and-exit")))))))
+    (home-page "https://github.com/philjackson/xmlgen")
+    (synopsis "S-expression to XML domain specific language (DSL) in
+Emacs Lisp")
+    (description "@code{emacs-xmlgen} provides S-expression to XML
+conversion for Emacs Lisp.")
+    (license license:gpl2+)))