summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-06-22 21:08:52 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-06-22 22:00:25 +0200
commit13151c326a2fb97d2d10e8fcf68d4bba15f20d1e (patch)
tree4308df770374197e6e39d3f01c3058240aca4a03
parenteeb8b0e631f6487a3bf138f23aa4792c4e3d3a2e (diff)
downloadguix-13151c326a2fb97d2d10e8fcf68d4bba15f20d1e.tar.gz
gnu: eid-mw: Don't use unstable tarball.
* gnu/packages/security-token.scm (eid-mw)[source]: Use GIT-FETCH.
-rw-r--r--gnu/packages/security-token.scm18
1 files changed, 9 insertions, 9 deletions
diff --git a/gnu/packages/security-token.scm b/gnu/packages/security-token.scm
index 9c8474dd02..eb89c2a5ca 100644
--- a/gnu/packages/security-token.scm
+++ b/gnu/packages/security-token.scm
@@ -28,6 +28,7 @@
   #:use-module ((guix licenses) #:prefix license:)
   #:use-module (guix packages)
   #:use-module (guix download)
+  #:use-module (guix git-download)
   #:use-module (guix build-system gnu)
   #:use-module (guix build-system glib-or-gtk)
   #:use-module (gnu packages autotools)
@@ -92,15 +93,14 @@ readers and is needed to communicate with such devices through the
   (package
     (name "eid-mw")
     (version "4.3.4")
-    (source (origin
-              (method url-fetch)
-              (uri (string-append
-                    "https://github.com/Fedict/eid-mw/archive/v"
-                    version ".tar.gz"))
-              (file-name (string-append name "-" version ".tar.gz"))
-              (sha256
-               (base32
-                "1ay9znry9dkhhn783paqy8czvv3w5gdpmq8ag8znx9akza8c929z"))))
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/Fedict/eid-mw")
+             (commit (string-append "v" version))))
+       (sha256
+        (base32 "0hrlk0k6vij2jjfwwqgcwv33aivln9flpkxbngk7hvg1s3al7ya1"))))
     (build-system glib-or-gtk-build-system)
     (native-inputs
      `(("autoconf" ,autoconf)