summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-07-09 11:55:43 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-07-09 17:07:36 +0200
commit1562763c0a3cf79a38f4087d5902f02fc09d98fc (patch)
tree8578b86c23769c264e70e4ce5ce47a00a214b43b
parent83c830d1ac010873f702c24542a184cfe07368e3 (diff)
downloadguix-1562763c0a3cf79a38f4087d5902f02fc09d98fc.tar.gz
gnu: Add texlive-latex-eso-pic.
* gnu/packages/tex.scm (texlive-latex-eso-pic): New variable.
-rw-r--r--gnu/packages/tex.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 01188a24a8..27266079e6 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -2103,6 +2103,26 @@ differs from the EC in a number of particulars.")
     (license (license:fsf-free "https://www.tug.org/svn/texlive/tags/\
 texlive-2017.1/Master/texmf-dist/doc/fonts/ec/copyrite.txt"))))
 
+(define-public texlive-latex-eso-pic
+  (package
+    (name "texlive-latex-eso-pic")
+    (version (number->string %texlive-revision))
+    (source (origin
+              (method svn-fetch)
+              (uri (texlive-ref "latex" "eso-pic"))
+              (sha256
+               (base32
+                "1xvmms28mvvfpks9x7lfya2xhh5k8jy3qnlih1mzcnf156xnb89z"))))
+    (build-system texlive-build-system)
+    (arguments '(#:tex-directory "latex/eso-pic"))
+    (home-page "http://www.ctan.org/pkg/eso-pic")
+    (synopsis "Add picture commands (or backgrounds) to every page")
+    (description
+     "The package adds one or more user commands to LaTeX's @code{shipout}
+routine, which may be used to place the output at fixed positions.  The
+@code{grid} option may be used to find the correct places.")
+    (license license:lppl1.3+)))
+
 (define-public texlive-latex-multirow
   (package
     (name "texlive-latex-multirow")