summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-04-01 09:16:24 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-04-01 09:16:24 +0300
commit17264e362c240bab2ee312fb4d3fca301b183624 (patch)
tree1d39be7a2f80af6f71395b7b659eed814de6b138
parentf12bd0bedde4fb6476064c5e2b32642c49857510 (diff)
downloadguix-17264e362c240bab2ee312fb4d3fca301b183624.tar.gz
gnu: emacs-discover-my-major: Don't use unstable tarball.
* gnu/packages/emacs-xyz.scm (emacs-discover-my-major)[source]: Download
using git-fetch. Use new upstream URI.
[home-page]: Update to new home-page.
-rw-r--r--gnu/packages/emacs-xyz.scm14
1 files changed, 7 insertions, 7 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index ed3e6f15cd..9a26d04853 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -13842,18 +13842,18 @@ throw a shell history.")
     (version "1.0")
     (source
      (origin
-       (method url-fetch)
-       (uri
-        (string-append "https://github.com/steckerhalter/discover-my-major"
-                       "/archive/" version ".tar.gz"))
-       (file-name (string-append name "-" version ".tar.gz"))
+       (method git-fetch)
+       (uri (git-reference
+              (url "https://framagit.org/steckerhalter/discover-my-major.git/")
+              (commit version)))
+       (file-name (git-file-name name version))
        (sha256
         (base32
-         "0nah41f92rrl2l405kpqr6iaks11jyclgl4z7ilfymbr4ifmsiyl"))))
+         "1wlqyl03hhnflbyay3qlvdzqzvv5rbybcjpfddggda7ias9h0pr4"))))
     (build-system emacs-build-system)
     (propagated-inputs
      `(("emacs-makey" ,emacs-makey)))
-    (home-page "https://github.com/steckerhalter/discover-my-major")
+    (home-page "https://framagit.org/steckerhalter/discover-my-major/")
     (synopsis "Discover key bindings for the current Emacs major mode")
     (description "This package provides allows to discover key bindings and
 their meaning for the current Emacs major-mode.")