summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-07-06 20:55:32 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-07-06 21:54:05 +0300
commit177be3a24df66d0461380c6e258209422f62543c (patch)
treee2b5c175d44860478b93f24d6f1afd94bbbcf53d
parentcc3205c1011936ddeeeb1b565b4070c6d15cc9aa (diff)
downloadguix-177be3a24df66d0461380c6e258209422f62543c.tar.gz
gnu: Add rust-thin-slice-0.1.
* gnu/packages/crates-io.scm (rust-thin-slice-0.1): New variable.
-rw-r--r--gnu/packages/crates-io.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index d32e7131a1..f46e82a35b 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -24493,6 +24493,27 @@ handle Unicode characters correctly.")
     (properties '((hidden? . #t)))
     (license license:expat)))
 
+(define-public rust-thin-slice-0.1
+  (package
+    (name "rust-thin-slice")
+    (version "0.1.1")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (crate-uri "thin-slice" version))
+        (file-name
+         (string-append name "-" version ".tar.gz"))
+        (sha256
+         (base32
+          "0g4z51g3yarah89ijpakbwhrrknw6d7k3ry0m1zqcn3hbhiq3alf"))))
+    (build-system cargo-build-system)
+    (home-page "https://github.com/heycam/thin-slice")
+    (synopsis
+     "Owned slice that packs the slice storage into a single word when possible")
+    (description
+     "An owned slice that packs the slice storage into a single word when possible.")
+    (license license:mpl2.0)))
+
 (define-public rust-thiserror-1.0
   (package
     (name "rust-thiserror")