summary refs log tree commit diff
diff options
context:
space:
mode:
authorAndy Patterson <ajpatter@uwaterloo.ca>2016-07-24 09:29:28 -0400
committer宋文武 <iyzsong@gmail.com>2016-07-25 19:50:13 +0800
commit1925a8792654434a22d2072cfd0f47c12ec869b6 (patch)
treec90765b2ce4b64d70914d6f46db33c618f0f8dd7
parent54a43ff4069c11e9944722e867518bfa677e196d (diff)
downloadguix-1925a8792654434a22d2072cfd0f47c12ec869b6.tar.gz
gnu: sbcl: Update to 1.3.7.
* gnu/packages/lisp.scm (sbcl): Update to 1.3.7.
[arguments]: During the patch-unix-tool-paths phase, avoid running
substitute* on a utf-16-be encoded file.

Signed-off-by: 宋文武 <iyzsong@gmail.com>
-rw-r--r--gnu/packages/lisp.scm10
1 files changed, 7 insertions, 3 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index 2f3442b8f5..5c0df4e1ff 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -218,14 +218,14 @@ an interpreter, a compiler, a debugger, and much more.")
 (define-public sbcl
   (package
     (name "sbcl")
-    (version "1.2.8")
+    (version "1.3.7")
     (source
      (origin
        (method url-fetch)
        (uri (string-append "mirror://sourceforge/sbcl/sbcl/" version "/sbcl-"
                            version "-source.tar.bz2"))
        (sha256
-        (base32 "0ab9lw056yf6y0rjmx3iirn5n59pmssqxf00fbmpyl6qsnpaja1d"))))
+        (base32 "0fjdqnb2rsm2vi9794ywp27jr239ddvzc4xfr0dk49jd4v7p2kc5"))))
     (build-system gnu-build-system)
     (outputs '("out" "doc"))
     ;; Bootstrap with CLISP.
@@ -252,7 +252,11 @@ an interpreter, a compiler, a debugger, and much more.")
                ;; occurs in some .sh files too (which contain Lisp code).  Use
                ;; ISO-8859-1 because some of the files are ISO-8859-1 encoded.
                (with-fluids ((%default-port-encoding #f))
-                 (substitute* (find-files "." "\\.(lisp|sh)$")
+                 ;; The removed file is utf-16-be encoded, which gives substitute*
+                 ;; trouble. It does not contain references to the listed programs.
+                 (substitute* (delete
+                               "./tests/data/compile-file-pos-utf16be.lisp"
+                               (find-files "." "\\.(lisp|sh)$"))
                    (("\"/bin/sh\"") (quoted-path bash "/bin/sh"))
                    (("\"/usr/bin/env\"") (quoted-path coreutils "/usr/bin/env"))
                    (("\"/bin/cat\"") (quoted-path coreutils "/bin/cat"))