summary refs log tree commit diff
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2019-06-20 12:15:07 +0200
committerAndreas Enge <andreas@enge.fr>2019-06-20 12:21:11 +0200
commit197ebc36be1dd44f90bcfbbaddda8632cdeff3d2 (patch)
treec8d462e417366125e7d07a2392e5d5eb4e98564d
parent66c67e7ba1b468dc3874fb9c84997992b7737181 (diff)
downloadguix-197ebc36be1dd44f90bcfbbaddda8632cdeff3d2.tar.gz
gnu: Add lrcalc.
* gnu/packages/algebra.scm (lrcalc): New variable.
-rw-r--r--gnu/packages/algebra.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index 810e9ce12a..1b401f8e5b 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -1490,3 +1490,39 @@ John Cremona to compute his elliptic curve database.")
     (license license:gpl2+)
     (home-page (string-append "http://homepages.warwick.ac.uk/staff/"
                               "J.E.Cremona/mwrank/index.html"))))
+
+(define-public lrcalc
+  (package
+    (name "lrcalc")
+    (version "1.2")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://bitbucket.org/asbuch/lrcalc")
+                    (commit (string-append "lrcalc-" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1c12d04jdyxkkav4ak8d1aqrv594gzihwhpxvc6p9js0ry1fahss"))))
+    (build-system gnu-build-system)
+    (native-inputs
+     `(("autoconf" ,autoconf)
+       ("automake" ,automake)
+       ("libtool" ,libtool)))
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-before 'build 'fix-permission
+           (lambda _
+             (chmod "lrcalc.maple.src" #o644)
+             #t)))))
+    (synopsis "Littlewood-Richardson calculator in algebraic combinatorics")
+    (description "The Littlewood-Richardson Calculator (lrcalc) is a
+program designed to compute Littlewood-Richardson coefficients.  It computes
+single Littlewood-Richardson coefficients, products of Schur functions, or
+skew Schur functions.  In addition it computes products in the small quantum
+cohomology ring of a Grassmann variety.  The software package also includes
+a program that performs fast computation of the more general multiplicative
+structure constants of Schubert polynomials.")
+    (license license:gpl2+)
+    (home-page "http://sites.math.rutgers.edu/~asbuch/lrcalc/")))