summary refs log tree commit diff
diff options
context:
space:
mode:
authorRutger Helling <rhelling@mykolab.com>2018-06-04 16:31:58 +0200
committerRutger Helling <rhelling@mykolab.com>2018-06-04 16:35:03 +0200
commit19b662ea7c53a28270a783f10ca033d8c9d2a954 (patch)
treef4e61062e0c100dec72707cbf72adf5c06f59664
parentfd174342496c8e4adeb273311dbe636b54b13bfa (diff)
downloadguix-19b662ea7c53a28270a783f10ca033d8c9d2a954.tar.gz
gnu: ranger: Enable image support.
* gnu/packages/disk.scm (ranger)[inputs]: Add 'w3m'.
[arguments]: Add wrapper for W3MIMGDISPLAY_PATH environment variable.
-rw-r--r--gnu/packages/disk.scm20
1 files changed, 19 insertions, 1 deletions
diff --git a/gnu/packages/disk.scm b/gnu/packages/disk.scm
index f5776ebda8..bdd24a315c 100644
--- a/gnu/packages/disk.scm
+++ b/gnu/packages/disk.scm
@@ -11,6 +11,7 @@
 ;;; Copyright © 2017 Stefan Reichör <stefan@xsteve.at>
 ;;; Copyright © 2018 Vasile Dumitrascu <va511e@yahoo.com>
 ;;; Copyright © 2018 Eric Bavier <bavier@member.fsf.org>
+;;; Copyright © 2018 Rutger Helling <rhelling@mykolab.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -53,6 +54,7 @@
   #:use-module (gnu packages guile)
   #:use-module (gnu packages compression)
   #:use-module (gnu packages vim)
+  #:use-module (gnu packages w3m)
   #:use-module (gnu packages xml))
 
 (define-public parted
@@ -516,12 +518,28 @@ Duperemove can also take input from the @command{fdupes} program.")
                (base32
                 "1lnzkrxcnlwnyi3z0v8ybyp8d5rm26qm35rr68kbs2lbs06inha0"))))
     (build-system python-build-system)
+    (inputs
+     `(("w3m" ,w3m)))
     (native-inputs                      ;for tests
      `(("python-pytest" ,python-pytest)
        ("python-pylint" ,python-pylint)
        ("python-flake8" ,python-flake8)
        ("which" ,which)))
-    (arguments '(#:test-target "test"))
+    (arguments
+     '(#:test-target "test"
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'configure 'wrap-program
+           ;; Tell 'ranger' where 'w3mimgdisplay' is.
+           (lambda* (#:key inputs outputs #:allow-other-keys)
+             (let* ((out  (assoc-ref outputs "out"))
+                    (ranger (string-append out "/bin/ranger"))
+                    (w3m (assoc-ref inputs "w3m"))
+                    (w3mimgdisplay (string-append w3m
+                                   "/libexec/w3m/w3mimgdisplay")))
+               (wrap-program ranger
+                 `("W3MIMGDISPLAY_PATH" ":" prefix (,w3mimgdisplay)))
+               #t))))))
     (home-page "https://ranger.github.io/")
     (synopsis "Console file manager")
     (description "ranger is a console file manager with Vi key bindings.  It