summary refs log tree commit diff
diff options
context:
space:
mode:
authorPaul van der Walt <paul@denknerd.org>2015-03-02 00:27:40 +0100
committerPaul van der Walt <paul@denknerd.org>2015-03-05 10:23:07 +0100
commit1a8bf1dc41d37f217828b7d0f2c61707ee028111 (patch)
treef7ef2426974e46242e03af5f63ef8d2ba5333f8f
parent279663efa57c0f02805f79408f6fe3aeca7ba1de (diff)
downloadguix-1a8bf1dc41d37f217828b7d0f2c61707ee028111.tar.gz
gnu: Add djvulibre.
* gnu/packages/djvu.scm (djvulibre): New variable.
* gnu-system.am: Add the file.
-rw-r--r--gnu-system.am1
-rw-r--r--gnu/packages/djvu.scm42
2 files changed, 43 insertions, 0 deletions
diff --git a/gnu-system.am b/gnu-system.am
index ec3feb0c66..b9c425ade4 100644
--- a/gnu-system.am
+++ b/gnu-system.am
@@ -81,6 +81,7 @@ GNU_SYSTEM_MODULES =				\
   gnu/packages/dejagnu.scm			\
   gnu/packages/dictionaries.scm			\
   gnu/packages/disk.scm				\
+  gnu/packages/djvu.scm				\
   gnu/packages/dnsmasq.scm			\
   gnu/packages/docbook.scm			\
   gnu/packages/doxygen.scm			\
diff --git a/gnu/packages/djvu.scm b/gnu/packages/djvu.scm
new file mode 100644
index 0000000000..47a76169f6
--- /dev/null
+++ b/gnu/packages/djvu.scm
@@ -0,0 +1,42 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2015 Paul van der Walt <paul@denknerd.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages djvu)
+  #:use-module ((guix licenses) #:prefix license:)
+  #:use-module (guix packages)
+  #:use-module (guix download)
+  #:use-module (guix build-system gnu))
+
+(define-public djvulibre
+  (package
+    (name "djvulibre")
+    (version "3.5.27")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "mirror://sourceforge/djvu/djvulibre-"
+                                  version ".tar.gz"))
+              (sha256
+               (base32
+                "0psh3zl9dj4n4r3lx25390nx34xz0bg0ql48zdskhq354ljni5p6"))))
+    (build-system gnu-build-system)
+    (home-page "http://djvu.sourceforge.net/")
+    (synopsis "Implementation of DjVu, the document format")
+    (description "DjVuLibre is an implementation of DjVu,
+including viewers, browser plugins, decoders, simple encoders, and
+utilities.")
+    (license license:gpl2+)))