summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2015-11-30 17:42:53 +0200
committerEfraim Flashner <efraim@flashner.co.il>2015-11-30 19:06:13 +0200
commit1c0059da41b4c0c0525ca75c5631f04495126814 (patch)
treeb9c6539ad34c4aa22fef86f4acf6801b275a56f4
parent36f26211bbb2c4dffe33427d4e65d5225a586a5b (diff)
downloadguix-1c0059da41b4c0c0525ca75c5631f04495126814.tar.gz
gnu: python2-pycrypto: Use python2.
* gnu/packages/python.scm (python2-pycrypto)[inputs]: Force building
with python2.
-rw-r--r--gnu/packages/python.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 39d0751f6a..d69c722de3 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -826,7 +826,13 @@ etc.).  The package is structured to make adding new modules easy.")
     (license public-domain)))
 
 (define-public python2-pycrypto
-  (package-with-python2 python-pycrypto))
+  (let ((pycrypto (package-with-python2 python-pycrypto)))
+    (package (inherit pycrypto)
+      (inputs
+       `(("python" ,python-2)
+         ,@(alist-delete
+            "python"
+            (package-inputs pycrypto)))))))
 
 (define-public python-keyring
   (package