summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2023-07-23 02:00:00 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2023-07-23 02:00:00 +0200
commit1d0d2a8ec9186d250405dce03a4cbe8809beb0f1 (patch)
tree4749822bdd2d72ca701d0143087b72f2db810498
parent08ae5d53e8dd79cec9df2cdfe382618f22fad48f (diff)
downloadguix-1d0d2a8ec9186d250405dce03a4cbe8809beb0f1.tar.gz
gnu: Add ghc-vty.
* gnu/packages/haskell-xyz.scm (ghc-vty): New public variable.
-rw-r--r--gnu/packages/haskell-xyz.scm42
1 files changed, 42 insertions, 0 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 1db3a157f1..c02fd007f9 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -13884,6 +13884,48 @@ and from some existing type with an Unbox instance.")
 given term should not exist.")
     (license license:bsd-3)))
 
+(define-public ghc-vty
+  (package
+  (name "ghc-vty")
+  (version "5.35.1")
+  (source
+   (origin
+     (method url-fetch)
+     (uri (hackage-uri "vty" version))
+     (sha256
+      (base32 "062dpz8fxrnggzpl041zpbph0xj56jki98ajm2s78dldg5vy0c9k"))))
+  (build-system haskell-build-system)
+  (native-inputs
+   (list ghc-hunit
+         ghc-quickcheck
+         ghc-quickcheck-assertions
+         ghc-random
+         ghc-smallcheck
+         ghc-string-qq
+         ghc-test-framework
+         ghc-test-framework-smallcheck
+         ghc-test-framework-hunit))
+  (inputs
+   (list ghc-ansi-terminal
+         ghc-blaze-builder
+         ghc-hashable
+         ghc-microlens
+         ghc-microlens-mtl
+         ghc-microlens-th
+         ghc-parallel
+         ghc-utf8-string
+         ghc-vector))
+  (arguments
+   `(#:cabal-revision ("1"
+                       "1zqcvgqhcij92241g20zn3c3a4033biid3f3cqg05q1ygrmznxb5")))
+  (properties '((upstream-name . "vty")))
+  (home-page "https://github.com/jtdaugherty/vty")
+  (synopsis "Simple terminal UI library")
+  (description
+   "vty is a terminal GUI library in the niche of ncurses, intended to be easy
+to use and to provide good support for common terminal types.")
+  (license license:bsd-3)))
+
 (define-public ghc-wave
   (package
     (name "ghc-wave")