summary refs log tree commit diff
diff options
context:
space:
mode:
authorBonfaceKilz <bonfacemunyoki@gmail.com>2020-10-15 19:39:38 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-10-18 12:31:23 +0300
commit1e3024540645894098b0ca6be5abb0f9f1987269 (patch)
treebd0f0252e4a239aa176739bc1bd1b4b0bb087471
parent545441735ada6d09894c2cf9bd3a1ca2353fed28 (diff)
downloadguix-1e3024540645894098b0ca6be5abb0f9f1987269.tar.gz
gnu: Add python2-openpyxl.
* gnu/packages/python-xyz.scm (python2-openpyxl): New package.
(python-openpyxl)[properties]: Add reference to python2-openpyxl.

Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/python-xyz.scm17
1 files changed, 17 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 6469e6726b..6360dc8f35 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -1666,8 +1666,25 @@ of @code{xmlfile}.")
     (description "This Python library allows reading and writing to the Excel XLSX, XLSM,
 XLTX and XLTM file formats that are defined by the Office Open XML (OOXML)
 standard.")
+    (properties  `((python2-variant . ,(delay python2-openpyxl))))
     (license license:expat)))
 
+(define-public python2-openpyxl
+  (let ((base (package-with-python2
+               (strip-python2-variant python-openpyxl))))
+    (package
+      (inherit base)
+      ;; This is the latest version that has python2 support
+      (version "2.6.4")
+      (source
+        (origin
+          (method url-fetch)
+          (uri (pypi-uri "openpyxl" version))
+          (sha256
+           (base32
+            "1qzjj8nwj4dn0mhq1j64f136afiqqb81lvqiikipz3g1g0b80lqx"))))
+      (arguments '(#:tests? #f)))))     ; No test suite.
+
 (define-public python-eventlet
   (package
     (name "python-eventlet")