summary refs log tree commit diff
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2015-12-29 14:52:04 +1000
committerBen Woodcroft <donttrustben@gmail.com>2016-01-26 16:21:05 +1000
commit1f1d71e09f1bc66ece977ed2e7be229c38cd0f5f (patch)
tree361f036a185807f39b9ff0b1ea70a32916e25cbc
parent72ccbfe3141a471a3dd403a19a3cdad7ab270f83 (diff)
downloadguix-1f1d71e09f1bc66ece977ed2e7be229c38cd0f5f.tar.gz
gnu: Add ruby-rc4.
* gnu/packages/ruby.scm (ruby-rc4): New variable.
-rw-r--r--gnu/packages/ruby.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index e107714bd4..fdfd9367c2 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -3207,3 +3207,29 @@ standard @code{Hash} making it possible to subclass and augment to fit any
 specific use case.")
     (home-page "http://rubyworks.github.io/hashery")
     (license license:bsd-2)))
+
+(define-public ruby-rc4
+  (package
+    (name "ruby-rc4")
+    (version "0.1.5")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (rubygems-uri "ruby-rc4" version))
+       (sha256
+        (base32
+         "00vci475258mmbvsdqkmqadlwn6gj9m01sp7b5a3zd90knil1k00"))))
+    (build-system ruby-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (replace 'check
+           (lambda _
+             (zero? (system* "rspec" "spec/rc4_spec.rb")))))))
+    (native-inputs
+     `(("ruby-rspec" ,ruby-rspec-2)))
+    (synopsis "Implementation of the RC4 algorithm")
+    (description
+     "RubyRC4 is a pure Ruby implementation of the RC4 algorithm.")
+    (home-page "https://github.com/caiges/Ruby-RC4")
+    (license license:expat)))