summary refs log tree commit diff
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2017-02-11 21:33:20 -0600
committerEric Bavier <bavier@member.fsf.org>2017-02-13 22:28:33 -0600
commit1f6ec9d22da2e62b1a7e55c2a516577dbd4457fa (patch)
tree3404451f189b6dd78bf9449db32c463276d2a25c
parent02a7a0caf4d159017755b9298f2f699fb0f46f46 (diff)
downloadguix-1f6ec9d22da2e62b1a7e55c2a516577dbd4457fa.tar.gz
gnu: Add nsgenbind.
* gnu/packages/web.scm (nsgenbind): New variable.
-rw-r--r--gnu/packages/web.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index ffd3c11e21..7d8cd29a58 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -4036,6 +4036,34 @@ developed as part of the NetSurf project.")
 Public Suffix List.  It is developed as part of the NetSurf project.")
     (license l:expat)))
 
+(define-public nsgenbind
+  (package
+    (name "nsgenbind")
+    (version "0.4")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "http://download.netsurf-browser.org/libs/releases/"
+                           name "-" version "-src.tar.gz"))
+       (sha256
+        (base32
+         "078gpbfcs96bgcba0ygha0ph9jzqr6ry5s3a8p6sl61px2908s66"))))
+    (build-system gnu-build-system)
+    (native-inputs
+     `(("netsurf-buildsystem" ,netsurf-buildsystem)
+       ("bison" ,bison)
+       ("flex" ,flex)))
+    (arguments
+     (substitute-keyword-arguments netsurf-buildsystem-arguments
+       ((#:make-flags flags)
+        `(delete "COMPONENT_TYPE=lib-shared" ,flags))))
+    (home-page "http://www.netsurf-browser.org/")
+    (synopsis "Generate JavaScript to DOM bindings")
+    (description
+     "@code{nsgenbind} is a tool to generate JavaScript to DOM bindings from
+w3c webidl files and a binding configuration file.")
+    (license l:expat)))
+
 (define-public netsurf
   (package
     (name "netsurf")