summary refs log tree commit diff
diff options
context:
space:
mode:
authorDavid Craven <david@craven.ch>2016-08-07 20:25:27 +0200
committerDavid Craven <david@craven.ch>2016-08-30 22:38:32 +0200
commit2128da9a98250881d6796d3b40a18a94f5624724 (patch)
tree1fdbf9724053ddb55df76c26fb58607c1b22ab32
parentdef00811a427db5e65f4cfbdcd2fd41e57a28b2c (diff)
downloadguix-2128da9a98250881d6796d3b40a18a94f5624724.tar.gz
gnu: Add ktextwidgets.
* gnu/packages/kde-frameworks.scm (ktextwidgets): New variable.
-rw-r--r--gnu/packages/kde-frameworks.scm45
1 files changed, 45 insertions, 0 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 9afbf900c1..17ccafb53a 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -2485,3 +2485,48 @@ can embed in your application, either as a KPart or using the KF5::TextEditor
 library.")
     ;; triple licensed
     (license (list license:gpl2+ license:lgpl2.0+ license:lgpl2.1+))))
+
+(define-public ktextwidgets
+  (package
+    (name "ktextwidgets")
+    (version "5.24.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://kde/stable/frameworks/"
+                           (version-major+minor version) "/"
+                           name "-" version ".tar.xz"))
+       (sha256
+        (base32
+         "1q10xav2gkii6s3m31c9xvxf1988l7k2lpib6pyhgsidflmwjm02"))))
+    (build-system cmake-build-system)
+    (propagated-inputs
+     `(("ki18n" ,ki18n)
+       ("sonnet" ,sonnet)))
+    (native-inputs
+     `(("extra-cmake-modules" ,extra-cmake-modules)))
+    (inputs
+     `(("kauth" ,kauth)
+       ("kcodecs" ,kcodecs)
+       ("kcompletion" ,kcompletion)
+       ("kconfig" ,kconfig)
+       ("kconfigwidgets" ,kconfigwidgets)
+       ("kcoreaddons" ,kcoreaddons)
+       ("kiconthemes" ,kiconthemes)
+       ("kservice" ,kservice)
+       ("kwidgetsaddons" ,kwidgetsaddons)
+       ("kwindowsystem" ,kwindowsystem)
+       ("qtbase" ,qtbase)))
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-before 'check 'check-setup
+           (lambda _
+             (setenv "QT_QPA_PLATFORM" "offscreen")
+             #t)))))
+    (home-page "https://community.kde.org/Frameworks")
+    (synopsis "Text editing widgets")
+    (description "KTextWidgets provides widgets for displaying and editing text.
+It supports rich text as well as plain text.")
+    ;; dual licensed
+    (license (list license:lgpl2.0+ license:lgpl2.1+))))