summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 16:58:22 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 19:42:34 +0200
commit24455759cdc7e03c655d13090b627eee489d4661 (patch)
treef69f4fdab34329c4c1a8dd16b25787ed655a601e
parentf261f23cf738e6822ea6f8c0f4b546d4873d2660 (diff)
downloadguix-24455759cdc7e03c655d13090b627eee489d4661.tar.gz
gnu: Add texlive-textopo.
* gnu/packages/tex.scm (texlive-textopo): New variable.
-rw-r--r--gnu/packages/tex.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index fea07d6636..e770d12a34 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -6721,6 +6721,25 @@ that support calculational proofs and Dijkstra's guarded command language.")
 symbols.")
     (license license:lppl)))
 
+(define-public texlive-textopo
+  (package
+    (name "texlive-textopo")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/textopo/" "source/latex/textopo/"
+                   "tex/latex/textopo/")
+             (base32
+              "0rw41qg3l4jzvwsrhwazwxn85kgad8r7bxp9bfbq843b4zrlwnaz")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/textopo")
+    (synopsis "Annotated membrane protein topology plots")
+    (description
+     "This package provides a LaTeX package for setting shaded and annotated
+membrane protein topology plots and helical wheels.")
+    (license license:gpl3+)))
+
 (define-public texlive-bibtex8
   (package
     (name "texlive-bibtex8")