summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-11-26 17:08:34 +0100
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-12-10 14:34:50 +0100
commit25101be9dcf633e9e9a2f12c7d05d2d62f3c3eff (patch)
treeaa0a02ef975c918b9bdc91ffd74c6ed99da9ab9d
parent1777e1f2cb37dffe2c99b87074beed49fb36cbf7 (diff)
downloadguix-25101be9dcf633e9e9a2f12c7d05d2d62f3c3eff.tar.gz
gnu: Add ghc-th-expand-syns.
* gnu/packages/haskell.scm (ghc-th-expand-syns): New variable.
-rw-r--r--gnu/packages/haskell.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index e49b0c50b9..cf5a1be87e 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -5235,6 +5235,28 @@ asynchronous exceptions.")
 datatypes.")
     (license bsd-3)))
 
+(define-public ghc-th-expand-syns
+  (package
+    (name "ghc-th-expand-syns")
+    (version "0.3.0.6")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "http://hackage.haskell.org/package/"
+                                  "th-expand-syns/th-expand-syns-"
+                                  version ".tar.gz"))
+              (sha256
+               (base32
+                "03qv93pyqk8all39knsf0mzmbfdck5x61kqnyn8rbisw5c1ymx6j"))))
+    (build-system haskell-build-system)
+    (propagated-inputs
+     `(("ghc-syb" ,ghc-syb)))
+    (home-page "http://hackage.haskell.org/package/th-expand-syns")
+    (synopsis "Expands type synonyms in Template Haskell ASTs")
+    (description
+     "This package enables users to expand type synonyms in Template Haskell
+@dfn{abstract syntax trees} (ASTs).")
+    (license bsd-3)))
+
 (define-public idris
   (package
     (name "idris")