summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-08-11 18:22:28 +0200
committerMarius Bakke <marius@gnu.org>2022-08-11 21:58:01 +0200
commit25a3d3514627ba219e5fb10249a89b57ec110772 (patch)
tree5f9001ef1ac2cd0f1f639577e638a356d093af77
parente3e678000d53fc85fcbed305f92aa0a17df414bb (diff)
downloadguix-25a3d3514627ba219e5fb10249a89b57ec110772.tar.gz
gnu: catch2@1: Adjust for glibc 2.34 and later.
* gnu/packages/check.scm (catch-framework2-1)[source](modules, snippet): New
fields.
-rw-r--r--gnu/packages/check.scm11
1 files changed, 10 insertions, 1 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 6ad2b1acd8..75bd20cff9 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -452,7 +452,16 @@ multi-paradigm automated test framework for C++ and Objective-C.")
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "1gdp5wm8khn02g2miz381llw3191k7309qj8s3jd6sasj01rhf23"))))
+                "1gdp5wm8khn02g2miz381llw3191k7309qj8s3jd6sasj01rhf23"))
+              (modules '((guix build utils)))
+              (snippet
+               '(substitute* '("include/internal/catch_fatal_condition.hpp"
+                               "single_include/catch.hpp")
+                  ;; In glibc 2.34 and later, SIGSTKSZ is no longer a
+                  ;; compile-time constant.  Hard code a reasonably large
+                  ;; value.
+                  (("SIGSTKSZ")
+                   "32768")))))
     (build-system cmake-build-system)
     (synopsis "Automated test framework for C++ and Objective-C")
     (description "Catch2 stands for C++ Automated Test Cases in Headers and is