summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-09-05 18:32:38 +0300
committerEfraim Flashner <efraim@flashner.co.il>2019-09-06 15:46:01 +0300
commit27438eb81725fe031d8d3bea7de45ef412e5b184 (patch)
tree5eda6771d2ddf5064dd56ba8a7493b00ecf5ed5b
parent1a9ce2a252cc75d9b7686ed4fcee9964d2b61eef (diff)
downloadguix-27438eb81725fe031d8d3bea7de45ef412e5b184.tar.gz
gnu: Add rust-filetime.
* gnu/packages/crates-io.scm (rust-filetime): New variable.
-rw-r--r--gnu/packages/crates-io.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index a56faa011b..971aec2e5d 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -594,6 +594,38 @@ provides implementations for @code{HashMap} and @code{HashSet}.")
     (license (list license:asl2.0
                    license:expat))))
 
+(define-public rust-filetime
+  (package
+    (name "rust-filetime")
+    (version "0.2.7")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (crate-uri "filetime" version))
+        (file-name (string-append name "-" version ".tar.gz"))
+        (sha256
+         (base32
+          "0sflihq2l77xjrza7yjalnxsc7dxzg25rhzcfbd9vmyfah5kimvb"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs
+       (("rust-cfg-if" ,rust-cfg-if)
+        ("rust-libc" ,rust-libc)
+        ("rust-redox-syscall" ,rust-redox-syscall)
+        ("rust-winapi" ,rust-winapi))
+       #:cargo-development-inputs
+       (("rust-tempdir" ,rust-tempdir))))
+    (home-page "https://github.com/alexcrichton/filetime")
+    (synopsis "Platform-agnostic accessors of timestamps in File metadata")
+    (description
+     "This library contains a helper library for inspecting and setting the
+various timestamps of files in Rust.  This library takes into account
+cross-platform differences in terms of where the timestamps are located, what
+they are called, and how to convert them into a platform-independent
+representation.")
+    (license (list license:asl2.0
+                   license:expat))))
+
 (define-public rust-findshlibs
   (package
     (name "rust-findshlibs")