summary refs log tree commit diff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-07-10 15:04:58 -0400
committerLeo Famulari <leo@famulari.name>2017-07-11 22:52:25 -0400
commit287900936b6b7e6b353f1e15a2d6315ef1ad80e0 (patch)
treecf932362a5429ebc1c3ebed36586410989e5d866
parente23cf9394e8b427432df6ea0360f4897ed9f692f (diff)
downloadguix-287900936b6b7e6b353f1e15a2d6315ef1ad80e0.tar.gz
gnu: man-db: Update to 2.7.6.1 [fixes CVE-2015-1336].
* gnu/packages/man.scm (man-db): Update to 2.7.6.1.
[arguments]: Add '--disable-cache-owner' to #:configure-flags.
-rw-r--r--gnu/packages/man.scm11
1 files changed, 8 insertions, 3 deletions
diff --git a/gnu/packages/man.scm b/gnu/packages/man.scm
index 101892a0a1..d8a64d1a86 100644
--- a/gnu/packages/man.scm
+++ b/gnu/packages/man.scm
@@ -57,14 +57,14 @@ a flexible and convenient way.")
 (define-public man-db
   (package
     (name "man-db")
-    (version "2.7.5")
+    (version "2.7.6.1")
     (source (origin
               (method url-fetch)
               (uri (string-append "mirror://savannah/man-db/man-db-"
                                   version ".tar.xz"))
               (sha256
                (base32
-                "056a3il7agfazac12yggcg4gf412yq34k065im0cpfxbcw6xskaw"))))
+                "0gqgs4zc3r87apns0k5qp689p2ylxx2596s2mkmkxjjay99brv88"))))
     (build-system gnu-build-system)
     (arguments
      '(#:phases
@@ -93,7 +93,12 @@ a flexible and convenient way.")
              (xz    (assoc-ref %build-inputs "xz"))
              (util  (assoc-ref %build-inputs "util-linux")))
          ;; Invoke groff, less, gzip, bzip2, and xz directly from the store.
-         (append (list "--disable-setuid" ;; Disable setuid man user.
+         (append (list ;; Disable setuid man user.
+                       "--disable-setuid"
+                       ;; Don't constrain ownership of system-wide cache files.
+                       ;; Otherwise creating the manpage database fails with
+                       ;; man-db > 2.7.5.
+                       "--disable-cache-owner"
                        (string-append "--with-pager=" less "/bin/less")
                        (string-append "--with-gzip=" gzip "/bin/gzip")
                        (string-append "--with-bzip2=" bzip2 "/bin/gzip")