summary refs log tree commit diff
diff options
context:
space:
mode:
authorMathieu Othacehe <m.othacehe@gmail.com>2018-01-08 16:19:53 +0100
committerMathieu Othacehe <m.othacehe@gmail.com>2018-01-08 16:19:53 +0100
commit2a67ff1f5e3c822e2603ec53cc8d263e394f66e5 (patch)
tree0271035f71a4009234c6db10051659674db8b09e
parent0215f94e69b133bf33f9bc54ea05df976dbfc9d8 (diff)
downloadguix-2a67ff1f5e3c822e2603ec53cc8d263e394f66e5.tar.gz
gnu: Add emacs-bongo.
* gnu/packages/emacs.scm (emacs-bongo): New variable.
-rw-r--r--gnu/packages/emacs.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index ebee6f61ba..964adf1ddf 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -6634,3 +6634,27 @@ mode’s f,F,t,T keys, allowing for quick navigation within a line.  It is a
 port of quick-scope for Vim.  Evil is an Emacs minor mode that emulates Vim
 features and provides Vim-like key bindings.")
     (license license:gpl3+)))
+
+(define-public emacs-bongo
+  (package
+    (name "emacs-bongo")
+    (version "1.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://github.com/dbrock/bongo/archive/"
+             version ".tar.gz"))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "1pcsyyrvj7djjjwpaswd1i782hvqvlvs39cy9ns0k795si6xd64d"))))
+    (build-system emacs-build-system)
+    (home-page "https://github.com/dbrock/bongo")
+    (synopsis "Media player for Emacs")
+    (description
+     "This package provides a flexible media player for Emacs.  @code{Bongo}
+supports multiple backends such as @code{vlc}, @code{mpg123},
+@code{ogg123}, @code{speexdec}, @code{timidity}, @code{mikmod} and
+@code{afplay}.")
+    (license license:gpl2+)))