summary refs log tree commit diff
diff options
context:
space:
mode:
authorhumanitiesNerd <catonano@gmail.com>2017-03-20 09:41:03 +0100
committerMarius Bakke <mbakke@fastmail.com>2017-03-21 12:55:43 +0100
commit2b9d2df799919014e9f989416589bb83eeccccad (patch)
tree9ea6cd779a049641b332216d98666544308613e6
parent4b9a5bd990a4c734828571147f9fec01c7053fcc (diff)
downloadguix-2b9d2df799919014e9f989416589bb83eeccccad.tar.gz
gnu: Add perl-crypt-rc4.
* gnu/pakages/perl.scm (perl-crypt-rc4): New variable.

Signed-off-by: Marius Bakke <mbakke@fastmail.com>
-rw-r--r--gnu/packages/perl.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 840e0b763e..04b9fa2862 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -14,6 +14,7 @@
 ;;; Copyright © 2016 Jan Nieuwenhuizen <janneke@gnu.org>
 ;;; Copyright © 2017 Raoul J.P. Bonnal <ilpuccio.febo@gmail.com>
 ;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2017 humanitiesNerd <catonano@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1369,6 +1370,26 @@ contained in Appendix A of FIPS Publication 181, \"Standard for Automated
 Password Generator\".")
     (license (package-license perl))))
 
+(define-public perl-crypt-rc4
+  (package
+    (name "perl-crypt-rc4")
+    (version "2.02")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "mirror://cpan/authors/id/S/SI/SIFUKURT/Crypt-RC4-"
+             version
+             ".tar.gz"))
+       (sha256
+        (base32
+         "1sp099cws0q225h6j4y68hmfd1lnv5877gihjs40f8n2ddf45i2y"))))
+    (build-system perl-build-system)
+    (home-page "http://search.cpan.org/dist/Crypt-RC4")
+    (synopsis "Perl implementation of the RC4 encryption algorithm")
+    (description "A pure Perl implementation of the RC4 algorithm.")
+    (license (package-license perl))))
+
 (define-public perl-cwd-guard
   (package
     (name "perl-cwd-guard")