summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-11-19 22:50:59 +0200
committerEfraim Flashner <efraim@flashner.co.il>2019-11-20 10:02:48 +0200
commit2c24b96b1013f4dddd97df68b4af8aa68181e8e8 (patch)
tree558c2b8bee25851057ef2cf1512aa73cd033ffe6
parentd71af69d1b02a304a8c5467bbd5a04e23e16fed0 (diff)
downloadguix-2c24b96b1013f4dddd97df68b4af8aa68181e8e8.tar.gz
gnu: cmark: Don't use unstable tarball.
* gnu/packages/markup.scm (cmark)[source]: Download using git-fetch.
-rw-r--r--gnu/packages/markup.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/markup.scm b/gnu/packages/markup.scm
index 911d929e97..216f01456d 100644
--- a/gnu/packages/markup.scm
+++ b/gnu/packages/markup.scm
@@ -198,13 +198,14 @@ implementation.
     (name "cmark")
     (version "0.28.3")
     (source (origin
-             (method url-fetch)
-             (uri (string-append "https://github.com/jgm/cmark/archive/"
-                                 version ".tar.gz"))
-             (file-name (string-append name "-" version ".tar.gz"))
+             (method git-fetch)
+             (uri (git-reference
+                    (url "https://github.com/jgm/cmark.git")
+                    (commit version)))
+             (file-name (git-file-name name version))
              (sha256
               (base32
-               "1z71pacl3ni1286c206pl8lazbcd32ackivsg3zibdf1sf2qdjdc"))))
+               "1lal6n6q7l84njgdcq1xbfxan56qlvr8xaw9m2jbd0jk4y2wkczg"))))
     (build-system cmake-build-system)
     (arguments
      '(#:test-target "test"))