summary refs log tree commit diff
diff options
context:
space:
mode:
authorAmin Bandali <mab@gnu.org>2020-02-02 15:16:49 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-02-02 15:16:49 +0100
commit2cb9b0453d87aaad15cb5c43702dfa8a109c53cb (patch)
tree557e8f062c4a5c72c08755d8237e5edb5c37aed8
parent2b19087496f0449c839e6c96cfeb952c5f6d8607 (diff)
downloadguix-2cb9b0453d87aaad15cb5c43702dfa8a109c53cb.tar.gz
gnu: Add emacs-switch-buffer-functions.
* gnu/packages/emacs-xyz.scm (emacs-switch-buffer-functions): New variable.
-rw-r--r--gnu/packages/emacs-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 1812a7b1af..3e8174663f 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -21238,6 +21238,29 @@ mode-line text (lighter) of major and minor modes.")
 matching a given regexp.")
       (license license:gpl2+))))
 
+(define-public emacs-switch-buffer-functions
+  (package
+    (name "emacs-switch-buffer-functions")
+    (version "0.0.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/10sr/switch-buffer-functions-el.git")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0pq53b8wrjbrxd5hnrcdi0z7mffp4bax55hn90k9ca3j76lhbn1k"))))
+    (build-system emacs-build-system)
+    (home-page "https://github.com/10sr/switch-buffer-functions-el")
+    (synopsis "Hooks run when switching current buffer")
+    (description "This package provides a hook variable
+@code{switch-buffer-functions}.  The hooks will be run when the current buffer
+is changed after an interactive command, i.e., when @code{post-command-hook}
+hooks are run.  The hooked functions will be called with both the previous and
+the current buffer.")
+    (license license:unlicense)))
+
 (define-public emacs-dmenu
   ;; Use the latest commit, as there are no tagged releases.
   (let ((commit "e8cc9b27c79d3ecc252267c082ab8e9c82eab264")