summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2017-03-21 07:55:49 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2017-03-22 02:03:31 +0100
commit2d431b0130e12f3774f0b639d54a79487673b299 (patch)
tree4ca43985a210e780a2a20b20e15965b9e76c1a32
parent7dbd75b3cff33c90c7427740be01542d1eff03b1 (diff)
downloadguix-2d431b0130e12f3774f0b639d54a79487673b299.tar.gz
gnu: dns: Return #t instead of something undefined.
* gnu/packages/dns.scm (yadifa, knot)[arguments]: Return #t after calling
‘substitute*’.
(knot)[source]: Return #t after calling ‘delete-file-recursively’.
-rw-r--r--gnu/packages/dns.scm12
1 files changed, 8 insertions, 4 deletions
diff --git a/gnu/packages/dns.scm b/gnu/packages/dns.scm
index d09abc1366..ec89abc670 100644
--- a/gnu/packages/dns.scm
+++ b/gnu/packages/dns.scm
@@ -294,8 +294,10 @@ asynchronous fashion.")
     (arguments
      `(#:phases (modify-phases %standard-phases
                   (add-before 'configure 'omit-example-configurations
-                              (lambda _ (substitute* "Makefile.in"
-                                          ((" (etc|var)") "")))))
+                              (lambda _
+                                (substitute* "Makefile.in"
+                                  ((" (etc|var)") ""))
+                                #t)))
        #:configure-flags (list "--sysconfdir=/etc"      "--localstatedir=/var"
                                "--enable-shared"        "--disable-static"
                                "--enable-messages"      "--enable-ctrl"
@@ -334,7 +336,8 @@ Extensions} (DNSSEC).")
                     (("contrib/dnstap ") ""))
                   (with-directory-excursion "src/contrib"
                     (for-each delete-file-recursively
-                              (list "dnstap" "lmdb")))))))
+                              (list "dnstap" "lmdb")))
+                  #t))))
     (build-system gnu-build-system)
     (native-inputs
      `(("pkg-config" ,pkg-config)))
@@ -354,7 +357,8 @@ Extensions} (DNSSEC).")
          (add-before 'configure 'disable-directory-pre-creation
            (lambda _
              ;; Don't install empty directories like ‘/etc’ outside the store.
-             (substitute* "src/Makefile.in" (("\\$\\(INSTALL\\) -d") "true"))))
+             (substitute* "src/Makefile.in" (("\\$\\(INSTALL\\) -d") "true"))
+             #t))
          (replace 'install
            (lambda* (#:key outputs #:allow-other-keys)
              (let* ((out (assoc-ref outputs "out"))