summary refs log tree commit diff
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2018-01-22 16:13:12 +0100
committerDanny Milosavljevic <dannym@scratchpost.org>2018-01-22 19:51:50 +0100
commit308124465249723f09ece2e461110eac12b1c49a (patch)
treeb3ba646242c2175c90c614e33170fbf1d904db8e
parent7ff72b3601c531ef0a5653d3c7f564116e6a3920 (diff)
downloadguix-308124465249723f09ece2e461110eac12b1c49a.tar.gz
gnu: aria-maestosa: Use scons-build-system.
* gnu/packages/music.scm (aria-maestosa)[build-system]: Use
scons-build-system.
[native-inputs]: Remove scons-python2.
[arguments]: Use scons-python2.
<#:phases>: Remove custom phases "build" and "install".
Add custom phase "fix-directory-permissions".
-rw-r--r--gnu/packages/music.scm22
1 files changed, 7 insertions, 15 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 4afac7ad72..4a49a550b9 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -134,11 +134,11 @@
               (sha256
                (base32
                 "1cs3z6frx2ch7rm5ammx9p0rxcjrbj1vq14hvcbimpaw39rdsn3d"))))
-    (build-system gnu-build-system)
+    (build-system scons-build-system)
     (arguments
      `(#:tests? #f  ;no tests
+       #:scons ,scons-python2
        #:phases
-       ;; TODO: Add scons-build-system and use it here.
        (modify-phases %standard-phases
          (delete 'configure)
          (add-after 'unpack 'scons-propagate-environment
@@ -161,26 +161,18 @@
                                " or \"score/\" in file"
                                " or \"Documentation/\" in file")))
              #t))
-         (replace 'build (lambda _ (zero? (system* "scons"))))
-         (replace 'install
+         (add-after 'install 'fix-directory-permissions
            (lambda* (#:key outputs #:allow-other-keys)
              (let ((out (assoc-ref outputs "out")))
-               (and
-                (zero? (system* "scons"
-                                (string-append "prefix=" out)
-                                "install"))
-                ;; Fix directory permissions
-                (begin
-                  (chmod (string-append out "/share/Aria/Documentation") #o555)
-                  (chmod (string-append out "/share/Aria/score") #o555)
-                  #t))))))))
+               (chmod (string-append out "/share/Aria/Documentation") #o555)
+               (chmod (string-append out "/share/Aria/score") #o555)
+               #t))))))
     (inputs
      `(("wxwidgets" ,wxwidgets)
        ("glib" ,glib)
        ("alsa-lib" ,alsa-lib)))
     (native-inputs
-     `(("scons" ,scons-python2)
-       ("pkg-config" ,pkg-config)))
+     `(("pkg-config" ,pkg-config)))
     (home-page "http://ariamaestosa.sourceforge.net/")
     (synopsis "MIDI sequencer and editor")
     (description