summary refs log tree commit diff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2018-08-26 15:24:40 +0200
committerJulien Lepiller <julien@lepiller.eu>2018-09-01 23:08:04 +0200
commit3224a5a84a261fcc8a6972ace1cbd0018371d34f (patch)
tree6251a3899fec90a65c5a3c69eaf1ec1204e9fa03
parentceac6f6f5bca77d541f793b2825d9de401be8aa6 (diff)
downloadguix-3224a5a84a261fcc8a6972ace1cbd0018371d34f.tar.gz
gnu: Add ruby-parallel.
* gnu/packages/ruby.scm (ruby-parallel): New variable.
-rw-r--r--gnu/packages/ruby.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 58cd6fc6d7..c3ce6ca39a 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -5405,3 +5405,22 @@ in Jekyll.")
     (description "This gems add the @code{--watch} switch to the jekyll CLI
 interface.  It allows Jekyll to rebuild your site when a file changes.")
     (license license:expat)))
+
+(define-public ruby-parallel
+  (package
+    (name "ruby-parallel")
+    (version "1.12.1")
+    (source (origin
+              (method url-fetch)
+              (uri (rubygems-uri "parallel" version))
+              (sha256
+               (base32
+                "01hj8v1qnyl5ndrs33g8ld8ibk0rbcqdpkpznr04gkbxd11pqn67"))))
+    (build-system ruby-build-system)
+    (arguments `(#:tests? #f)); No rakefile
+    (home-page "https://github.com/grosser/parallel")
+    (synopsis "Parallel processing in Ruby")
+    (description "Parallel allows you to run any code in parallel Processes
+(to use all CPUs) or Threads(to speedup blocking operations).  It is best
+suited for map-reduce or e.g. parallel downloads/uploads.")
+    (license license:expat)))