summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-01-19 18:35:18 +0100
committerMarius Bakke <mbakke@fastmail.com>2017-02-19 23:29:57 +0100
commit361d982ce36591fad86e0da8d5dca16ff8ed098d (patch)
treef8de8c75225e16fe0c07fc93ad0c37dbccb4710a
parentb35f442e623e0ec7db82dc92db2b42f9e26580d2 (diff)
downloadguix-361d982ce36591fad86e0da8d5dca16ff8ed098d.tar.gz
gnu: Add python-cycler.
* gnu/packages/python.scm (python-cycler, python2-cycler): New variables.
-rw-r--r--gnu/packages/python.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 3e59b58928..432298472a 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -3601,6 +3601,36 @@ transcendental functions).")
 (define-public python2-numexpr
   (package-with-python2 python-numexpr))
 
+(define-public python-cycler
+  (package
+    (name "python-cycler")
+    (version "0.10.0")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "cycler" version))
+              (sha256
+               (base32
+                "1n69n23fak1gjxlrbhqisi2b9pv3ckrfj98llx3p53953082syyd"))))
+    (build-system python-build-system)
+    (arguments
+     ;; XXX: The current version requires 'coveralls' which we don't have.
+     ;; Enable this for the next release which uses 'python-pytest'.
+     '(#:tests? #f))
+    (propagated-inputs
+     `(("python-six" ,python-six)))
+    (home-page "http://matplotlib.org/cycler/")
+    (synopsis "Composable keyword argument iterator")
+    (description
+     "When using @code{matplotlib} and plotting more than one line, it is
+common to want to be able to want to be able to cycle over one or more artist
+styles; but the plotting logic can quickly become involved.
+To address this and enable easy cycling over arbitrary @code{kwargs}, the
+@code{Cycler} class was developed.")
+    (license license:bsd-3)))
+
+(define-public python2-cycler
+  (package-with-python2 python-cycler))
+
 (define-public python-matplotlib
   (package
     (name "python-matplotlib")